Search found 6 matches

by jwu
Wed Jun 24, 2020 6:51 pm
Forum: Pending
Topic: [0.18.32] Crash on save: FluidBox::getFluidManager()
Replies: 5
Views: 630

Re: [0.18.32] Crash on save: FluidBox::getFluidManager()

Thanks, I can try that. No access to my machine for 2 weeks, but I'll try to post and share the saves later. Thanks
by jwu
Tue Jun 23, 2020 3:28 am
Forum: Pending
Topic: [0.18.32] Crash on save: FluidBox::getFluidManager()
Replies: 5
Views: 630

Re: [0.18.32] Crash on save: FluidBox::getFluidManager()

Loewchen wrote: ↑
Sun Jun 21, 2020 1:19 pm
What makes you think the crashes are random?
Correction: I am unaware why I am getting SIGSEGV errors. Sometimes autosaving works, sometimes autosave is the last event before the SIGSEGV.
by jwu
Sun Jun 21, 2020 7:03 am
Forum: Pending
Topic: [0.18.32] Crash on save: FluidBox::getFluidManager()
Replies: 5
Views: 630

[0.18.32] Crash on save: FluidBox::getFluidManager()

Getting random segmentation fault errors I think while autosaving.

Just updated to the experimental latest available in arch's AUR. Game has been crashing on both [0.17.79] and current [0.18.32].
factorio-current.log
(12.87 KiB) Downloaded 48 times
Thanks!
by jwu
Sat Jun 20, 2020 6:48 pm
Forum: Pending
Topic: [0.18.18] Crash loading save: "fluidBox->connections[connectionRecord.connectionIndex].target == nullptr was not true"
Replies: 9
Views: 850

Re: [0.18.18] Crash loading save: "fluidBox->connections[connectionRecord.connectionIndex].target == nullptr was not tru

Hey Rseding91, I am working with [0.17.79] and all of my save files suddenly cannot be opened. I haven't updated and have been playing offline for a few days. Are you suggesting I just abandon my saves? I posted here, because there was a similar error message that I saw on my crash logs, but if the ...
by jwu
Sat Jun 20, 2020 3:25 am
Forum: Pending
Topic: [0.18.18] Crash loading save: "fluidBox->connections[connectionRecord.connectionIndex].target == nullptr was not true"
Replies: 9
Views: 850

Re: [0.18.18] Crash loading save: "fluidBox->connections[connectionRecord.connectionIndex].target == nullptr was not tru

Hi,

I am seeing the same issue on version [0.17.79] and unable to load any of my saves.
factorio-current.log
(5.91 KiB) Downloaded 39 times
Hoping to get some help.

Thanks!

Edit: Here is one of the affected save files
_autosave2.zip
(18.96 MiB) Downloaded 33 times

Go to advanced search