[boskid][1.1.30] Produced fluid disappears

This subforum contains all the issues which we already resolved.
Post Reply
gaddhi
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Sep 09, 2017 4:36 pm
Contact:

[boskid][1.1.30] Produced fluid disappears

Post by gaddhi »

In an Angel & Bob-modded game I created a pipe connection between two chemical plants with the expectation that the pipe transports the fluid from the output port of the first chemical plant into the input port of the second chemical plant. However the fluid disappears and does not even appear in the pipe.
Here is a screenshot of the setup:
pipebug.png
pipebug.png (117.68 KiB) Viewed 2355 times
In this attached savegame the situation is that the bug is present:
PipeBug.zip
(5.36 MiB) Downloaded 70 times
As a workaround I am able to get the expected behavior by the following procedure:
1. delete the pipe between the two chemical plants (the left one in the screenshot)
2. place a new pipe at the same location

In the savegame I am able to trigger the bug more or less reliably (20% of all cases or more often) by
1. deleting the two plants and all surrounding structures (with ctrl-x)
2. pressing ctrl-z in order to let bots build the setup new

I have not managed to trigger this bug when placing the structures by hand - it seems like this only happens when building with bots.
Attachments
factorio-current.log
(38.64 KiB) Downloaded 60 times

User avatar
boskid
Factorio Staff
Factorio Staff
Posts: 1908
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

Re: [boskid][1.1.30] Produced fluid disappears

Post by boskid »

Thanks for the report. Issue is now fixed for 1.1.31.

This was yet another weird corner case for the automatic fluid system purge logic which failed to detect that the fluidsystem had fluids above the threshold. It failed because the fluid content was able to cross 2 connections (50.0 from producer to pipe, then 50.0 from pipe to consumer) during single fluidbox update which messed with the purge check. The automatic purge logic was changed to one that will never fail again - it was removed entirely.

gaddhi
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Sep 09, 2017 4:36 pm
Contact:

Re: [boskid][1.1.30] Produced fluid disappears

Post by gaddhi »

Thank you for resolving this problem so quickly.

Post Reply

Return to “Resolved Problems and Bugs”