[kovarex] [1.1.26/27] Blueprints have weird behavior with mods

This subforum contains all the issues which we already resolved.
Post Reply
oof2win2
Inserter
Inserter
Posts: 31
Joined: Wed Nov 18, 2020 8:13 am
Contact:

[kovarex] [1.1.26/27] Blueprints have weird behavior with mods

Post by oof2win2 »

When using my mod, https://mods.factorio.com/mod/no-belts, belts can be removed completely from the blueprint library. Mod has been marked as deprecated due to this very reason.

Steps to reproduce:
  • 1. Have a blueprint in your personal library containing belts (fig. 1)
    2. Enable the mod
    3. Change personal library contents (fig. 2)
    4. Disable the mod
    5. Blueprints that contained belts no longer have belts in them and they don't work (fig. 3)
Edit: important thing is to save the game in-between steps (Curiosity mentions creating a new save between steps 2 and 3 too)
Edit2: Works with mod version 0.4.2 or below, different approach used for 0.4.3.
Since I'm a noob with mods, I asked for help from Curiosity on Discord, for reference the link is here https://discord.com/channels/1396775903 ... 6506865715

Also attached the save, though not sure how useful that will be.
Attachments
test.zip
(2.05 MiB) Downloaded 20 times
fig3
fig3
Screenshot 2021-03-12 at 14.46.47.png (257.77 KiB) Viewed 611 times
fig2
fig2
Screenshot 2021-03-12 at 14.45.28.png (225.32 KiB) Viewed 611 times
fig1
fig1
Screenshot 2021-03-12 at 14.38.23.png (264.94 KiB) Viewed 611 times

kovarex
Factorio Staff
Factorio Staff
Posts: 8045
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [1.1.26/27] Blueprints have weird behavior with mods

Post by kovarex »

Hello and thanks for the report.

We always tried to make sure that the blueprint library wouldn't be damaged by adding/removing mods, and it was done quite some time ago
https://www.factorio.com/blog/post/fff-211
https://factorio.com/blog/post/fff-357

Your case is specific in a way, that the mod doesn't actually remove belts, it just makes them not buildable from the belt items. This confused our logic, as there is a check, that when entity is not suitable to be in blueprint anymore, it gets removed from it, and the condition of not being suitable for blueprint is also the requirement of having some items that can build the item. And this removal didn't mark the blueprint to be "preserved in the original state", as other removals do.

TL;DR Fixed for the next version.

oof2win2
Inserter
Inserter
Posts: 31
Joined: Wed Nov 18, 2020 8:13 am
Contact:

Re: [kovarex] [1.1.26/27] Blueprints have weird behavior with mods

Post by oof2win2 »

thanks!

Post Reply

Return to “Resolved Problems and Bugs”