[0.18.37] Random desync without mods

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
NotRexButCaesar
Smart Inserter
Smart Inserter
Posts: 1006
Joined: Sun Feb 16, 2020 12:47 am
Contact:

[0.18.37] Random desync without mods

Post by NotRexButCaesar »

The title says it all. I have no idea why it is de-syncing, as i am not using any mods. I am connecting to my friend through a free server hosting service that has worked before, and the world is brand new. The de-sync occurs upon loading the map.
Last edited by NotRexButCaesar on Thu Jul 30, 2020 6:42 am, edited 3 times in total.
III: Think about what you intend to accomplish with an action before execution.
Have you ever heard the gospel? Most have not.

User avatar
NotRexButCaesar
Smart Inserter
Smart Inserter
Posts: 1006
Joined: Sun Feb 16, 2020 12:47 am
Contact:

Re: [0.18.37] Random desync without mods

Post by NotRexButCaesar »

The attachment didn't submit, so I'm sending it again.
Attachments
desync-report-2020-07-29_23-33-11.zip
The de sync report.
(4.68 MiB) Downloaded 28 times
III: Think about what you intend to accomplish with an action before execution.
Have you ever heard the gospel? Most have not.

User avatar
NotRexButCaesar
Smart Inserter
Smart Inserter
Posts: 1006
Joined: Sun Feb 16, 2020 12:47 am
Contact:

Re: [0.18.37] Random desync without mods

Post by NotRexButCaesar »

Update: the server also crashed upon turning off. I can't get a crash report. When joining using the steam client, rather than the standalone, it worked.
III: Think about what you intend to accomplish with an action before execution.
Have you ever heard the gospel? Most have not.

User avatar
boskid
Factorio Staff
Factorio Staff
Posts: 1528
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

Re: [0.18.37] Random desync without mods

Post by boskid »

This desync happens due to the issue with loading player's blueprint shelf which has modded entities (most likely of different prototype type that need extra migration). Issue should be fixed for 0.18.39

Post Reply

Return to “Resolved Problems and Bugs”