[0.18.36] Inserters in blueprints lose configuration when upgraded using upgrade planner

This subforum contains all the issues which we already resolved.
Post Reply
Jemsterr
Inserter
Inserter
Posts: 30
Joined: Tue Jan 07, 2020 11:23 am
Contact:

[0.18.36] Inserters in blueprints lose configuration when upgraded using upgrade planner

Post by Jemsterr »

Seablock, using bob's adjustable inserters.

If I have an inserter that has its configuration changed (input, output, whatever)
Inserter with input from side and near drop
Inserter with input from side and near drop
Before.png (63.8 KiB) Viewed 1341 times
and I use an upgrade planner on it, those settings are preserved.

If you blueprint that inserter (that includes the temporary blueprint you get when using shift while copying!) and drop an upgrade planner in the green box on that blueprint to upgrade/downgrade it, it loses all configuration options (input/output rotation, near/far drop).
After upgrading from red to green using green box in blueprint
After upgrading from red to green using green box in blueprint
After.png (60.85 KiB) Viewed 1341 times
I reported this to bobingabout, and he said it would be best to report it here, since it is a base-game issue.
Attachments
Inserters.zip
Save file - if needed
(16.69 MiB) Downloaded 78 times
factorio-previous.log
log files - if needed
(83.44 KiB) Downloaded 80 times
factorio-current.log
log files - if needed
(87.48 KiB) Downloaded 76 times
Last edited by Jemsterr on Sun Jul 19, 2020 11:59 am, edited 1 time in total.

Loewchen
Global Moderator
Global Moderator
Posts: 7517
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.18.36] Insterters in blueprints lose configuration when upgraded using upgrade planner

Post by Loewchen »

Ref.: 65462 This is a reference, if you do not understand why it exists, ignore it.

Rseding91
Factorio Staff
Factorio Staff
Posts: 12283
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.18.36] Inserters in blueprints lose configuration when upgraded using upgrade planner

Post by Rseding91 »

Thanks for the report. It's now fixed for the next release.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”