[Rseding] [0.18.17] Blueprint doesn't save Rollingstock runtime tint

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
lovely_santa
Filter Inserter
Filter Inserter
Posts: 495
Joined: Sat Feb 18, 2017 9:41 pm
Contact:

[Rseding] [0.18.17] Blueprint doesn't save Rollingstock runtime tint

Post by lovely_santa »

Hello,

Trains can be tinted in the base game, but there is support to have a runtime tint to all rolling stock, including cargo wagons. I can easily set the runtime tint for these as shown in the picture below. However, when I create a blueprint, only the (red) tint on the locomotive is maintained, the runtime tint on the cargo wagon is not, and just returns to the default tint given in the prototype data. It's not only the preview, when pasting the blueprint, the wagon is colored orange (and not red)

I've attached the save file to reproduce this. I could not upload the mod here for some reason (maybe 30MB is too big?) So I've uploaded it on wetransfer: https://we.tl/t-i7a7rnSsS0 (just ask if I need to re-upload it)

Kind regards
lovely_santa
CargoWagonTinting.PNG
CargoWagonTinting.PNG (3.49 MiB) Viewed 959 times
Attachments
CargoWagonTinting.zip
(1.1 MiB) Downloaded 90 times
You can find all my mods on the mod portal. Also helping on Arch666Angel's mods.
Image

Rseding91
Factorio Staff
Factorio Staff
Posts: 12218
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding] [0.18.17] Blueprint doesn't save Rollingstock runtime tint

Post by Rseding91 »

Thanks for the report. It's now fixed for the next release.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”