[0.17.79] Desync on vanilla server

This subforum contains all the issues which we already resolved.
Post Reply
matjojo
Filter Inserter
Filter Inserter
Posts: 317
Joined: Wed Jun 17, 2015 6:08 pm
Contact:

[0.17.79] Desync on vanilla server

Post by matjojo »

(report)[https://www99.zippyshare.com/v/ugz5SMzo/file.html]

I'm playing on a server with three people. I was the only one online at the time and had just joined, though I'm not sure if it was at the first tick or after a couple seconds, not
more than 20 seconds for sure though.

We have a relatively small map of around 60 megabytes.

I had a request open for 10K red ammo that our network was NOT able to provide for.

I had just build several new wall sections in another session. (So I went offline for a while in between building those and coming online just now)
The server is set up to pause when no-one is online.

I'm running on a laptop (HP ZBook Studio G5) with an i7-8750H @ 2.20GHz (stock) 16 gigs of ram and a Quadro P1000.

User avatar
boskid
Factorio Staff
Factorio Staff
Posts: 869
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

Re: [0.17.79] Desync on vanilla server

Post by boskid »

Thanks for the report. I was looking into this desync report at least 4 times and finally yesterday i was able to find a semi-reliable way to reproduce this desync. It was related to transport lines merging. Issue is now fixed for 0.18.34.

matjojo
Filter Inserter
Filter Inserter
Posts: 317
Joined: Wed Jun 17, 2015 6:08 pm
Contact:

Re: [0.17.79] Desync on vanilla server

Post by matjojo »

Wow that is incredible, I had completely forgot about this desyc. I'm constantly amazed at your incredible dedication. Thanks a lot:)

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users