[posila] [0.17.65] Blueprinted train doesn't snap to station properly

This subforum contains all the issues which we already resolved.
Post Reply
TwoPizzas
Burner Inserter
Burner Inserter
Posts: 8
Joined: Wed Jun 26, 2019 7:13 am
Contact:

[posila] [0.17.65] Blueprinted train doesn't snap to station properly

Post by TwoPizzas »

Only the first locomotive snaps to station, the rest of the train is free to be moved along the rails like placing a regular wagon. When placed, the train doesn't snap to station and just gets placed wherever the rest of the train was.
Image
Got the "get hit by a train" achievement before the "build a train" achievement.

kovarex
Factorio Staff
Factorio Staff
Posts: 8058
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.65] Blueprinted train doesn't snap to station properly

Post by kovarex »

Yes, blueprinted train isn't supposed to snap to station.

TwoPizzas
Burner Inserter
Burner Inserter
Posts: 8
Joined: Wed Jun 26, 2019 7:13 am
Contact:

Re: [kovarex] [0.17.65] Blueprinted train doesn't snap to station properly

Post by TwoPizzas »

Shouldn't the locomotive at least stay visually connected to the train and not try to snap to station?
Got the "get hit by a train" achievement before the "build a train" achievement.

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 5030
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [kovarex] [0.17.65] Blueprinted train doesn't snap to station properly

Post by Klonan »

TwoPizzas wrote:
Tue Aug 27, 2019 10:15 am
Shouldn't the locomotive at least stay visually connected to the train and not try to snap to station?
Yea, it looks buggy to me:



I will move this back to assigned

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.65] Blueprinted train doesn't snap to station properly

Post by posila »

For 0.17.67 fixed that the preview would snap to the train stop.
Thanks for the report.

Post Reply

Return to “Resolved Problems and Bugs”