[wheybags]Consistent crash in intro scenario

This subforum contains all the issues which we already resolved.
Post Reply
Snalin
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sat Aug 03, 2019 1:22 pm
Contact:

[wheybags]Consistent crash in intro scenario

Post by Snalin »

I've got consistent scenario crash in the intro scenario.

To repro, load up the attached save, and run down to the right. Deconstruct the rightmost lab by the wayer. The scenario crashes after a bit - or immediately if you wait a few seconds before deconstructing

Code: Select all

The scenario level caused a non-recoverable error.
Please report this error to the scenario author.

Error while running event level::on_tick (ID 0)
LuaEntity API call when LuaEntity was invalid.
stack traceback:
	__base__/lualib/npe/helper-branches.lua:1202: in function 'condition'
	__core__/lualib/story_2.lua:191: in function 'update'
	__base__/lualib/npe/helper_story.lua:40: in function '?'
	__base__/lualib/event_handler.lua:7: in function <__base__/lualib/event_handler.lua:4>
stack traceback:
	[C]: in function '__index'
	__base__/lualib/npe/helper-branches.lua:1202: in function 'condition'
	__core__/lualib/story_2.lua:191: in function 'update'
	__base__/lualib/npe/helper_story.lua:40: in function '?'
	__base__/lualib/event_handler.lua:7: in function <__base__/lualib/event_handler.lua:4>
Attachments
GamesGottenUpdated.zip
Save game for repro
(1.67 MiB) Downloaded 70 times

User avatar
wheybags
Former Staff
Former Staff
Posts: 328
Joined: Fri Jun 02, 2017 1:50 pm
Contact:

Re: [wheybags]Consistent crash in intro scenario

Post by wheybags »

Thanks for the report.
Fixed for the next version

Post Reply

Return to “Resolved Problems and Bugs”