[Rseding91] Music volume setting not saved [0.17.59-8]

This subforum contains all the issues which we already resolved.
Post Reply
garionh
Burner Inserter
Burner Inserter
Posts: 5
Joined: Sun Apr 09, 2017 8:10 am
Contact:

[Rseding91] Music volume setting not saved [0.17.59-8]

Post by garionh » Sat Jul 27, 2019 9:42 pm

Hey,

This is a minor issue obviously. I prefer not to have the music when playing Factorio, so I set the music volume to 0 (Esc, Settings, Sounds, music volume slider to 0%, confirm, Esc, Esc).

That setting works for the rest of the session while I play the game, but if I save and exit (Esc, Save game, Save, Quit Game, Exit), then restart the game (via Steam) later, the music is playing again when I load the game.

I expect that once set and saved, the music volume should be retained in the save file for this game. I recently switched from Windows to Linux, and did not have this issue in Windows.

Workaround is simply to re-set the music volume level each gaming session.

Logfile: https://pastebin.com/bu1kjqqg

OkraDonkey
Burner Inserter
Burner Inserter
Posts: 12
Joined: Sat Dec 16, 2017 1:24 pm
Contact:

Re: Music volume setting not saved [0.17.59-8]

Post by OkraDonkey » Sun Jul 28, 2019 8:49 am

This is happening in the Windows version, too (also 0.17.59). Factorio doesn't seem to be saving the adjusted music volume setting into config.ini. After manually changing music-volume in config.ini, Factorio loads with the correct music volume level.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9793
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] Music volume setting not saved [0.17.59-8]

Post by Rseding91 » Sun Jul 28, 2019 6:08 pm

Thanks for the report. It's now fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users