[0.17.59] Crash during NPE intro campaign (bad 2nd arg to random)

This subforum contains all the issues which we already resolved.
Post Reply
Madman
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sun Jul 17, 2016 4:42 am
Contact:

[0.17.59] Crash during NPE intro campaign (bad 2nd arg to random)

Post by Madman »

Happened during new player experience campaign playthrough. Was just running across the level, not interacting with any object.

Intro campaign was started on an earlier version of 0.17 if that matters, but crash happened in latest experimental.

Campaign worked fine if I reloaded from the latest autosave and continued, which I expected given it was a call to random that failed. Hopefully there's enough info in the log to be able to reproduce the issue, as I forgot to copy the save before I reloaded the game, sorry!
factorio-npe-crash.png
factorio-npe-crash.png (2.46 MiB) Viewed 1485 times
Attachments
factorio-current.log
Log file including crash at end
(59.81 KiB) Downloaded 64 times

Mister.Blonde
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sat Jul 27, 2019 11:08 am
Contact:

Re: [0.17.59] Crash during NPE intro campaign (bad 2nd arg to random)

Post by Mister.Blonde »

Hi,

I go the same error during the campain (where I'm supposed to automate science and ammo).

I tired to restart the campain, two times, and I got the same error at the same moment.

Thanks in advance for the fix.

Bilka
Factorio Staff
Factorio Staff
Posts: 2853
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: [0.17.59] Crash during NPE intro campaign (bad 2nd arg to random)

Post by Bilka »

Thanks for the report, fixed for the next version.
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

Madman
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sun Jul 17, 2016 4:42 am
Contact:

Re: [0.17.59] Crash during NPE intro campaign (bad 2nd arg to random)

Post by Madman »

Thanks Bilka! <3

Post Reply

Return to “Resolved Problems and Bugs”