[0.17.59] Rebound Filter Slot Broken

This subforum contains all the issues which we already resolved.
Post Reply
Primar13
Manual Inserter
Manual Inserter
Posts: 4
Joined: Wed Feb 27, 2019 4:53 am
Contact:

[0.17.59] Rebound Filter Slot Broken

Post by Primar13 »

The Filter Slot ability defaults to Middle Mouse Button. I have that rebound to be Alt + Left Mouse Button due to issues with broken MMB on mice in the past.

This rebinding broke as of today with the 0.17.59 release. Can you please allow us to use a Modifier Key + LMB for the Filter Slot Function

[Edit]

I did a little extra testing, and it seems you cannot use a Modifier key (Ctrl,Shift,Alt) and the Left/Right Mouse Button as a Keybind for Filter Slot.
However, you can use them as a Modifier for Middle Mouse Button.

Added log, took me a while to find it.
factorio-current.log
Primar13 - Filter Slot Logfile
(6.6 KiB) Downloaded 71 times
Attachments
factorio-current.log
Primar13 - Filter Slot Logfile
(6.6 KiB) Downloaded 59 times

slippycheeze
Filter Inserter
Filter Inserter
Posts: 587
Joined: Sun Jun 09, 2019 10:40 pm
Contact:

Re: [0.17.59] Rebound Filter Slot Broken

Post by slippycheeze »

I also have this problem, and sorely miss my alt-left click to clear the filter. It does work for me with control, though, so I'm uncertain what the similarity is. I did check thoroughly for conflicting keybindings and cannot find any that could cause the problem.

I have only tried filter clearing on my quickslots at this time.

slippycheeze
Filter Inserter
Filter Inserter
Posts: 587
Joined: Sun Jun 09, 2019 10:40 pm
Contact:

Re: [0.17.59] Rebound Filter Slot Broken

Post by slippycheeze »

This persists in 0.17.60, which since it was not mentioned in the changelog is almost certainly expected, but now also, confirmed.

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.59] Rebound Filter Slot Broken

Post by posila »

Thank you for taking the time to post bug report.

Should be fixed for 0.17.63

Post Reply

Return to “Resolved Problems and Bugs”