[posila] [0.17.58] Fluids don't unload randomly

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
ssilk
Global Moderator
Global Moderator
Posts: 12717
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

[posila] [0.17.58] Fluids don't unload randomly

Post by ssilk »

Sorry. I had this bug now several times and I want to get rid of it, but I'm not 100% if it is a Factorio bug or a bug of the many mods I use, because of the random nature of this bug: I cannot just remove a mod and look, if it was that, cause the error won't repeat then (but at any time later). Maybe in the end it's because I use a Mac - who knows? :)

So here is the description: Sometimes fluid trains forget to unload. They come to a fluid train unload-station, the pumps connect, but the tanks are not emptied. (And yes: The station-tanks in this picture are only about half filled, enough space to put oil from 6 trains in.)

Looks like so:
Screenshot 2019-07-20 at 09.22.34.png
Screenshot 2019-07-20 at 09.22.34.png (1.27 MiB) Viewed 2144 times
I have a save here:
https://drive.google.com/file/d/1yFp9gs ... sp=sharing

After about 30 seconds this train arrives here. Sorry for the size - it's 85 MB and uses over 100 mods.

PS: I tried to figure out, if it is caused by train specific mod (e.g. removed realistic train accelleration mod and such stuff). When I change some mod settings or do any other smaller or bigger change to the game, the error cannot be repeated, but happens at any time somewhere else. But I'm far from saying that it is a mod., which causes this, cause every test-run takes about 15 minutes.

PPS: I hunt for this bug now several month, and in 0.16 this bug brought my hair to fall out, cause it happens all the time, that sulfur acid was filled into crude oil. With 0.17 this cannot happen anymore, but is still quite irritating. For those, who interested: I use the LTN-mod and there are two depots for Liquids (the stations names are "DepotL"). In them I build an alarming system, which fires, when a non-empty train comes in. With that I could go back to the moment, when it happens.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2605
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: [0.17.58] Fluids don't unload randomly

Post by steinio »

Is this still the LTN leave station if empty but tank wagon isn't problem?

#fluidsrounddown #changefluidrounding #fluidsshouldbeints
Image
Transport Belt Repair Man

View unread Posts

Bilka
Factorio Staff
Factorio Staff
Posts: 2853
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: [0.17.58] Fluids don't unload randomly

Post by Bilka »

steinio wrote:
Sat Jul 20, 2019 9:29 am
Is this still the LTN leave station if empty but tank wagon isn't problem?

#fluidsrounddown #changefluidrounding #fluidsshouldbeints
No. The train doesn't go to the stop properly, so it is in the wrong position and the pumps don't connect. Here is a save literally ticks before that happens: https://drive.google.com/file/d/1WkQ1aK ... sp=sharing
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.58] Fluids don't unload randomly

Post by posila »

Thanks for the report.
It happened because a mod was messing with speed of breaking train. It should be fixed for 0.17.59

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 12717
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [posila] [0.17.58] Fluids don't unload randomly

Post by ssilk »

Thank you.

Just for interest: Which mod? Was it https://mods.factorio.com/mod/OverloadedTrains ?
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.58] Fluids don't unload randomly

Post by posila »

I haven't checked yesterday, so I took a look today and yes.

You wrote it eventually happens without the mod too, which I am not sure why, but I am confident the fix will apply to those cases too.

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 12717
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [posila] [0.17.58] Fluids don't unload randomly

Post by ssilk »

I checked that twice: I turned the mod off and that error happens then about 15 minutes later from that Save (with 0.17.58).

Maybe the mod changes more, which is not completely reset after removal?

I’ll check it agin with the current version.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

Post Reply

Return to “Resolved Problems and Bugs”