[kovarex] [0.17.56] Inconsistent (not allowed) rail signal placement

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
tzwaan
Inserter
Inserter
Posts: 36
Joined: Thu Jul 07, 2016 12:12 am
Contact:

[kovarex] [0.17.56] Inconsistent (not allowed) rail signal placement

Post by tzwaan » Sun Jul 14, 2019 2:38 am

The player is unable to place a signal on the diagonal track between the two curves, but when one of the curves is removed, the signal can be placed down, after which the curve can be put back in place with the signal still being in a working state. Updating the blocks adjacent to the signal by adding extra signals will make this signal invalid again, but otherwise the signal keeps working correctly.

Expected behavior: Either the signal should be able to be put there, or the signal should stop working the moment the curve is put back.

I'd personally expect the signal to be allowed to be placed there, since there's clearly space for it, and it is able to be placed when either of the curves is removed, which means it's not too close to either of them to normally be placed.
Attachments
bugreport.png
bugreport.png (1.94 MiB) Viewed 503 times

kovarex
Factorio Staff
Factorio Staff
Posts: 7424
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.56] Inconsistent (not allowed) rail signal placement

Post by kovarex » Mon Jul 15, 2019 1:07 pm

Good find, thanks for it, fixed for the next version.

The bug was, that the new logic of checking for smaller boxes for segment collision wasn't properly applied in one specific place.

User avatar
tzwaan
Inserter
Inserter
Posts: 36
Joined: Thu Jul 07, 2016 12:12 am
Contact:

Re: [kovarex] [0.17.56] Inconsistent (not allowed) rail signal placement

Post by tzwaan » Mon Jul 15, 2019 4:39 pm

I assume the fix is that you are allowed to place it there?

kovarex
Factorio Staff
Factorio Staff
Posts: 7424
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.56] Inconsistent (not allowed) rail signal placement

Post by kovarex » Mon Jul 15, 2019 8:09 pm

tzwaan wrote:
Mon Jul 15, 2019 4:39 pm
I assume the fix is that you are allowed to place it there?
Yes, the rail the signal connects to don't collide (when using the rail segment collision boxes) with the other rails, so the placement is completely valid. You can test it out, as 0.17.57 is out.

User avatar
tzwaan
Inserter
Inserter
Posts: 36
Joined: Thu Jul 07, 2016 12:12 am
Contact:

Re: [kovarex] [0.17.56] Inconsistent (not allowed) rail signal placement

Post by tzwaan » Tue Jul 16, 2019 2:20 am

Yeah, I noticed. I already put it into practice, as seen here: https://www.reddit.com/r/factorio/comme ... ispsa_are/

Which was also how I found this bug in the first place.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: Hermitude