[Klonan] Logistic system tutorial bug!

This subforum contains all the issues which we already resolved.
Post Reply
n0escape200
Manual Inserter
Manual Inserter
Posts: 1
Joined: Tue Jul 09, 2019 10:59 am
Contact:

[Klonan] Logistic system tutorial bug!

Post by n0escape200 » Tue Jul 09, 2019 11:02 am

I wanted to play the tutorial on the logistics robors and i got an error
"The scenario level caused a non-recoverable error.
Please report this error to the scenario author.

Error while running event level::on_tick (ID 0)
Callable only on entities that have request slots.
stack traceback:
...ing/Factorio/temp/currently-playing-tutorial/control.lua:145: in function 'init'
__core__/lualib/story.lua:66: in function 'story_update'
...ing/Factorio/temp/currently-playing-tutorial/control.lua:590: in function <...ing/Factorio/temp/currently-playing-tutorial/control.lua:583>
stack traceback:
[C]: in function 'set_request_slot'
...ing/Factorio/temp/currently-playing-tutorial/control.lua:145: in function 'init'
__core__/lualib/story.lua:66: in function 'story_update'
...ing/Factorio/temp/currently-playing-tutorial/control.lua:590: in function <...ing/Factorio/temp/currently-playing-tutorial/control.lua:583>"
Attachments
fabug.png
fabug.png (188.87 KiB) Viewed 234 times

cobalt_crysis
Manual Inserter
Manual Inserter
Posts: 1
Joined: Wed Jul 10, 2019 12:29 am
Contact:

Re: Logistic system tutorial bug!

Post by cobalt_crysis » Wed Jul 10, 2019 12:31 am

I also have this exact same issue. I am currently running 17.55 and created the world in 17.54. Running on Windows 10 and have done the tutorial before.

Loewchen
Global Moderator
Global Moderator
Posts: 5201
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Logistic system tutorial bug!

Post by Loewchen » Wed Jul 10, 2019 5:15 am

Are you using mods when playing the tuturial?

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 3642
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: Logistic system tutorial bug!

Post by Klonan » Wed Jul 10, 2019 7:46 am

I know what happened,

Its fixed for the next release

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users