[0.17.54] [Map Editor] A DP in Map Editor cannot remove tiles

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
TheBloke
Long Handed Inserter
Long Handed Inserter
Posts: 85
Joined: Mon Dec 03, 2018 2:48 am
Contact:

[0.17.54] [Map Editor] A DP in Map Editor cannot remove tiles

Post by TheBloke » Mon Jul 08, 2019 10:28 pm

Platform tested on: Windows 10 & macOS 10.14.5
Version tested: 0.17.54

A Deconstruction Planner used in Map Editor (mode: "None") will select but not remove any user-placed tiles, eg refined concrete.

When using a DP on tiles they will select as expected, as shown in this screenshot:
Image

But upon releasing the mouse button, nothing happens; the tiles remain in place. If a DP is used on both entities and tiles (DP: Tiles->Always), then both are selected, but only the entities are removed.

Tested with:
  • A blank, unfiltered DP;
  • A DP set to Tiles->Only;
  • A DP set to Tiles->Always;
  • A DP filtered to the type of tile being selected, eg refined concrete.
Tiles can be removed in Map Editor using normal tile mining, or by painting other tiles over the top, or by using Clone. So it's not a major problem. But using a DP is usually my first thought, and in some circumstances will be the quickest method to use, so it would be helpful if it were possible for it to work in Map Editor as it does in the normal game.

Thanks.

User avatar
TheBloke
Long Handed Inserter
Long Handed Inserter
Posts: 85
Joined: Mon Dec 03, 2018 2:48 am
Contact:

Re: [0.17.54] [Map Editor] A DP in Map Editor cannot remove tiles

Post by TheBloke » Thu Jul 11, 2019 7:15 pm

Thanks very much for the fix.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: posila