[kovarex] [0.17.54] Strongly increased belt speed breaks splitter filter

This subforum contains all the issues which we already resolved.
Post Reply
Anon2k
Long Handed Inserter
Long Handed Inserter
Posts: 55
Joined: Thu Aug 02, 2018 8:51 am
Contact:

[kovarex] [0.17.54] Strongly increased belt speed breaks splitter filter

Post by Anon2k »

Good afternoon, I played with the ultimate belts mod (https://mods.factorio.com/mod/UltimateBelts), but after updating 0.17.52, filtering stopped working correctly for me. I thought the problem was in mod.

However, I turned off all the mods and wrote my local mod, which increases the speed of vanilla belts 4 times (60, 120, 180): https://pastebin.com/1bHP6Vtn

Image

And at a speed of 180 / s, the objects periodically skip past filtering. I assume this happens for any speed above 120 / s.
Last edited by Anon2k on Mon Jul 08, 2019 10:07 pm, edited 1 time in total.

Anon2k
Long Handed Inserter
Long Handed Inserter
Posts: 55
Joined: Thu Aug 02, 2018 8:51 am
Contact:

Re: splitter filter bug

Post by Anon2k »


Rothguard
Burner Inserter
Burner Inserter
Posts: 11
Joined: Sat Apr 14, 2018 4:40 pm
Contact:

Re: [0.17.54] Strongly increased belt speed breaks splitter filter

Post by Rothguard »

i will confirm this happens on faster belts and i think it also happens if game speed increased to silly speeds

mrvn
Smart Inserter
Smart Inserter
Posts: 5112
Joined: Mon Sep 05, 2016 9:10 am
Contact:

Re: [0.17.54] Strongly increased belt speed breaks splitter filter

Post by mrvn »

Rothguard wrote:
Thu Jul 11, 2019 9:27 am
i will confirm this happens on faster belts and i think it also happens if game speed increased to silly speeds
That makes no sense. No matter the game speed the game updates are still done tick by tick. The game speed actually just adds a sleep between updates to slow the game down.

kovarex
Factorio Staff
Factorio Staff
Posts: 8058
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.54] Strongly increased belt speed breaks splitter filter

Post by kovarex »

I tried to reproduce the problem, but it seemed to work well for me (4Xtimes fast express belts).
Could you please provide a save where this is reproduced?
Attachments
fast-belts.png
fast-belts.png (480.01 KiB) Viewed 4372 times

Anon2k
Long Handed Inserter
Long Handed Inserter
Posts: 55
Joined: Thu Aug 02, 2018 8:51 am
Contact:

Re: [kovarex] [0.17.54] Strongly increased belt speed breaks splitter filter

Post by Anon2k »

You just have items on the belts too ordered on the sides. Need more chaos :D

My savegame from the video above: https://drive.google.com/open?id=1VF-Ud ... WVWkZ6DLS9
Just scatter the plastic on the chests on both sides of the conveyor and 100% is reproduced, the steel periodically passes through the plastic filter.

Anon2k
Long Handed Inserter
Long Handed Inserter
Posts: 55
Joined: Thu Aug 02, 2018 8:51 am
Contact:

Re: [kovarex] [0.17.54] Strongly increased belt speed breaks splitter filter

Post by Anon2k »

kovarex wrote:
Thu Jul 11, 2019 1:07 pm
I tried to reproduce the problem, but it seemed to work well for me (4Xtimes fast express belts).
Could you please provide a save where this is reproduced?
Now you reproduced the bug? Or do you need something else besides video and savegame?

Owoshima
Manual Inserter
Manual Inserter
Posts: 4
Joined: Mon Jul 15, 2019 1:49 am
Contact:

Re: [kovarex] [0.17.54] Strongly increased belt speed breaks splitter filter

Post by Owoshima »

kovarex wrote:
Thu Jul 11, 2019 1:07 pm
I tried to reproduce the problem, but it seemed to work well for me (4Xtimes fast express belts).
That shouldn't be a fix though, since you're only using half the belt, the problem comes with a mixed belt, which requires a proper fix.

As such, as it currently stands this bug has caused a big mess in my lines.
(I'm not angry about the lines, that's an easy fix thank's to your quick solution :) I'm just saying it's shouldn't be a permanent solution)

mrvn
Smart Inserter
Smart Inserter
Posts: 5112
Joined: Mon Sep 05, 2016 9:10 am
Contact:

Re: [kovarex] [0.17.54] Strongly increased belt speed breaks splitter filter

Post by mrvn »

Owoshima wrote:
Mon Jul 15, 2019 1:53 am
kovarex wrote:
Thu Jul 11, 2019 1:07 pm
I tried to reproduce the problem, but it seemed to work well for me (4Xtimes fast express belts).
That shouldn't be a fix though, since you're only using half the belt, the problem comes with a mixed belt, which requires a proper fix.

As such, as it currently stands this bug has caused a big mess in my lines.
(I'm not angry about the lines, that's an easy fix thank's to your quick solution :) I'm just saying it's shouldn't be a permanent solution)
You mean because one side of the belt is all copper and the other all iron instead of them being all mixed?

kovarex
Factorio Staff
Factorio Staff
Posts: 8058
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.54] Strongly increased belt speed breaks splitter filter

Post by kovarex »

Thanks for the report, it is now fixed for the next release.

Owoshima
Manual Inserter
Manual Inserter
Posts: 4
Joined: Mon Jul 15, 2019 1:49 am
Contact:

Re: [kovarex] [0.17.54] Strongly increased belt speed breaks splitter filter

Post by Owoshima »

Hooray!

Post Reply

Return to “Resolved Problems and Bugs”