[0.17.53] Sync mods with save doesn't sync correctly under a specific condition

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
Therenas
Factorio Staff
Factorio Staff
Posts: 213
Joined: Tue Dec 11, 2018 2:10 pm
Contact:

[0.17.53] Sync mods with save doesn't sync correctly under a specific condition

Post by Therenas »

When syncing mods with a save from the load save screen, it sometimes enables mods that should be disabled. To reproduce this, follow these steps:

- Download the attached save
- Download the mods stdlib and pycoalprocessing
- Open the game, enable pycoalprocessing and disable stdlib
- On reload, notice how pycoalprocessing is not loaded because it is missing it's required dependecy stdlib
- Now, sync to the save. This activates stdlib
- On reload, pycoalprocessing is now also loaded, because stdlib is loaded

This is not intended, because the save does not contain pycoalprocessing. pycoalprocessing should be disabled.
(This is not specific to those mods, they just serve as an illustration. It's anytime there is a mod with a hard dependency on another mod)
Attachments
example.zip
(1.27 MiB) Downloaded 70 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 12224
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.53] Sync mods with save doesn't sync correctly under a specific condition

Post by Rseding91 »

Thanks for the report. It's now fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”