[0.17.50] Mod manager can fail to allow "Update selected"

This subforum contains all the issues which we already resolved.
Post Reply
Ralp
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat May 05, 2018 2:14 pm
Contact:

[0.17.50] Mod manager can fail to allow "Update selected"

Post by Ralp »

Mod manager can fail to allow the user to update selected mods under specific conditions. Example:
Image
https://imgur.com/gallery/cEssqfD
Note: LTN is selected and "Update selected" is not allowed

Reproduction: At least 2 mods that need updating are required.
  1. Select a mod (preferably a large mod that will take a while to update, or a list of mods that will also take a while to update).
  2. Click on "Update selected".
  3. While the mods are updating, select another mod (or other mods).
  4. Once the mods that were previously selected have finished updating, you will have mods selected and not be allowed to click "Update selected".
~ Ralp

Edit: Can't get the image to embed

Rseding91
Factorio Staff
Factorio Staff
Posts: 12217
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.50] Mod manager can fail to allow "Update selected"

Post by Rseding91 »

Thanks for the report. It's now fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”