[kovarex] [0.17.49] Crash, signal-ghost at forbidden position: "*this->reservedFor == train was not true"

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
boskid
Factorio Staff
Factorio Staff
Posts: 1790
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

[kovarex] [0.17.49] Crash, signal-ghost at forbidden position: "*this->reservedFor == train was not true"

Post by boskid »

Weak Ref 71724
Weak Ref 71917

Code: Select all

0.003 2019-06-13 21:22:17; Factorio 0.17.49 (build 45696, win64, steam)
---

Steps to reproduce:
1/ Open save (contains replay data to see what i did):
crash-invalid-ghost.zip
(240.92 KiB) Downloaded 69 times
2/ Wait 2s
3/ Crash
log
---

Core issue is that if you have tracks, signals have to be separated at least by 2 tiles. This is achived by showing this green "lollipops" showing where you can place signals. If you place signal, tiles 1 in each direction will now be shown as invalid spot for placing signal (no lollipop). Issue is that i was able to manually rotate signal in hand and shift-place it (place ghost) in forbidden spot. After building it by robot, game instantly crashes

Lets call this issue "invalid rail signal position bypass" as without shift, there is alert "invalid rail signal position" for trying to build signal in this forbidden spot.

For this issue to show, there must be train running. Without it signal will just be placed. If in this state train is set to automatic mode, it will just show "no-path"

Issue works also in straight sections:
crash-invalid-ghost-horizontal.zip
(252.74 KiB) Downloaded 66 times
After extensive testing:
- there must be train running
- crash is only when placing signal-ghost on opposite side, exactly 1 tile after existing signal (if existing signal is on bottom, ghost must be on top side, 1 tile to right as in image below)
- signal-ghost must be in correct orientation to affect train segments

invalid-rail-position.png
invalid-rail-position.png (491.16 KiB) Viewed 1685 times

th0
Inserter
Inserter
Posts: 37
Joined: Sat Mar 16, 2019 12:04 pm
Contact:

Re: [0.17.49] Crash, signal-ghost at forbidden position: "*this->reservedFor == train was not true"

Post by th0 »

shitherewego.png
shitherewego.png (614.32 KiB) Viewed 1679 times

User avatar
boskid
Factorio Staff
Factorio Staff
Posts: 1790
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

Re: [0.17.49] Crash, signal-ghost at forbidden position: "*this->reservedFor == train was not true"

Post by boskid »

Another case of same issue:
0/ preconditions: loop with running train, 2 waypoints, at least 2 rail segments (as in first post), signals only on one side
1/ enter editor
2/ use Ctrl+C to copy signal
3/ Rotate it to match direction of adhoc-blueprint in hand to opposite side of track
4/ Place blueprint with above signal on opposite side, 1 tile to front.
5/ As editor does silent revive of pasted blueprints, this crashes with different stack trace
log

kovarex
Factorio Staff
Factorio Staff
Posts: 8058
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.49] Crash, signal-ghost at forbidden position: "*this->reservedFor == train was not true"

Post by kovarex »

Thanks for the report, it is fixed for the next release.

Post Reply

Return to “Resolved Problems and Bugs”