Extreme slowdown after artillery does its job

This subforum contains all the issues which we already resolved.
Post Reply
dugen
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sat Jun 08, 2019 1:53 am
Contact:

Extreme slowdown after artillery does its job

Post by dugen »

I decided to play deathworld defaults with no mods for my first playthrough of 0.17 and this is my first time using artillery extensively. I've noticed that whenever I expand into new space and setup new guns the game slows down dramatically. I've gotten in the habit of keeping my expansions small and starting the guns working before bed so the problem will be cleared up by morning. From what I can tell, it's the result of having such a large number of enemy existing in the world at one time. It seems to clear up as the biters that are spawned during the bombardment eventually make their way to the walls and die. It can take a few hours, sometimes 10 or 12. The bigger the expansion, the bigger the slowdown and the more real-world time it takes to clear up. I'm currently running at about 12 ups after a relatively small 2 wall expansion. This is on an i7-9700k that holds pretty steady at 4.57ghz with a GeForce 2080 for graphics so I expect the problem will be worse for most people. The game runs quite smoothly usually and even large construction projects barely give it trouble, but these wall expansions are brutal which seems silly since from what I can tell, the enemies don't move or do anything most of the time. I suspect they are doing something per-tick that they maybe shouldn't be.

Here's a link to my save file since I'm not sure if the attachment worked:
https://drive.google.com/file/d/1z7o2am ... sp=sharing
Attachments
Screenshot (23).png
Screenshot (23).png (1.23 MiB) Viewed 2419 times
factorio-current.log
(67.32 KiB) Downloaded 69 times

User avatar
BattleFluffy
Fast Inserter
Fast Inserter
Posts: 171
Joined: Sun Mar 31, 2019 4:58 pm
Contact:

Re: Extreme slowdown after artillery does its job

Post by BattleFluffy »

Hi friend :> That sounds like the same problem we've been having over in this thread.

Rseding91
Factorio Staff
Factorio Staff
Posts: 11923
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: Extreme slowdown after artillery does its job

Post by Rseding91 »

BattleFluffy wrote:
Mon Jun 10, 2019 4:58 pm
Hi friend :> That sounds like the same problem we've been having over in this thread.
It is the same-ish thing. The artillery turrets aggro all of the biters in the area they just shot at which are now trying to run over and attack the artillery and all of the running-over is taking a ton of CPU time (see entity update).
If you want to get ahold of me I'm almost always on Discord.

dugen
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sat Jun 08, 2019 1:53 am
Contact:

Re: Extreme slowdown after artillery does its job

Post by dugen »

It is the same-ish thing. The artillery turrets aggro all of the biters in the area they just shot at which are now trying to run over and attack the artillery and all of the running-over is taking a ton of CPU time (see entity update).
In my game the biters don't move, sometimes for hours, after their base has been destroyed. When they do finally attack they tend to focus on the turrets so they must remember what attacked their base but until then they don't move. They seem to do nothing but slow things down.

Oxyd
Factorio Staff
Factorio Staff
Posts: 1397
Joined: Thu May 07, 2015 8:42 am
Contact:

Re: Extreme slowdown after artillery does its job

Post by Oxyd »

dugen wrote:
Mon Jun 10, 2019 10:05 pm
It is the same-ish thing. The artillery turrets aggro all of the biters in the area they just shot at which are now trying to run over and attack the artillery and all of the running-over is taking a ton of CPU time (see entity update).
In my game the biters don't move, sometimes for hours, after their base has been destroyed. When they do finally attack they tend to focus on the turrets so they must remember what attacked their base but until then they don't move. They seem to do nothing but slow things down.
That's because there's simply too many of them aggroed at you at the same time, and they're all trying to pathfind toward the base. With that many biters, that's going to take a long time.

In 0.17.49 I've made some changes to reduce the UPS impact of this, although it's still not perfect. And the biters still appear frozen whilst they're waiting for their turn on the pathfinder.

Post Reply

Return to “Resolved Problems and Bugs”