[Twinsen] [0.17.34] Belt immunity empties batteries in power armor

This subforum contains all the issues which we already resolved.
Post Reply
marco_
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sun Apr 28, 2019 2:55 pm
Contact:

[Twinsen] [0.17.34] Belt immunity empties batteries in power armor

Post by marco_ »

Hi

I have a strange behavior of the belt immunity equipment. If I leave the server and rejoin it after a while (my server is configured with auto pause off), the batteries in my power armor are complete depleted and start recharge. How can this be? Is my character a sleep walker? ;-) When I'm playing with the belt immunity installed the batteries stay charged (discharge normally).

tehfreek
Filter Inserter
Filter Inserter
Posts: 391
Joined: Thu Mar 17, 2016 7:34 am
Contact:

Re: [0.17.34] Belt immunity empties batteries in power armor

Post by tehfreek »

Belt immunity equipment is always active, and it seems that power sources are not active when logged out.

Twinsen
Factorio Staff
Factorio Staff
Posts: 1240
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [0.17.34] Belt immunity empties batteries in power armor

Post by Twinsen »

I can't reproduce the issue, my batteries and equipment work the same way when I log in and out of a headless server with auto pause.

I will need more details.

Zavian
Smart Inserter
Smart Inserter
Posts: 1616
Joined: Thu Mar 02, 2017 2:57 am
Contact:

Re: [0.17.34] Belt immunity empties batteries in power armor

Post by Zavian »

Twinsen wrote:
Tue Apr 30, 2019 2:21 pm
I can't reproduce the issue, my batteries and equipment work the same way when I log in and out of a headless server with auto pause.
My reading of marco_'s post is that he was talking about a server with auto pause turned off.

Twinsen
Factorio Staff
Factorio Staff
Posts: 1240
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [Twinsen] [0.17.34] Belt immunity empties batteries in power armor

Post by Twinsen »

My bad. I could reproduce it now.

See also: viewtopic.php?f=48&t=67149

marco_
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sun Apr 28, 2019 2:55 pm
Contact:

Re: [Twinsen] [0.17.34] Belt immunity empties batteries in power armor

Post by marco_ »

Sorry for the long delay....

It's right, my server has auto pause is off and you have to stay away quite some time (depending how many batteries are equipped)...

But I see you could reproduce it....

Rseding91
Factorio Staff
Factorio Staff
Posts: 12205
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Twinsen] [0.17.34] Belt immunity empties batteries in power armor

Post by Rseding91 »

Fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”