[Oxyd] [0.17.32] Crash when connecting to server (InputActionDefragmenter::assemble)

This subforum contains all the issues which we already resolved.
Post Reply
luc
Fast Inserter
Fast Inserter
Posts: 218
Joined: Sun Jul 17, 2016 9:53 pm
Contact:

[Oxyd] [0.17.32] Crash when connecting to server (InputActionDefragmenter::assemble)

Post by luc »

Just got a crash trying to connect to the stress test while it was trying to catch up. I don't think it caught up, it was going quite slow, though I alt-tabbed away so I can't be sure.

I turned off crash uploading because I hadn't had a crash in years and I'd report it manually anyway. I understand there should be a crash dump, but I can't find any in the game folder. I looked in saves, data (the root of that folder only), temp, bin, $PWD, and the game root. (I started factorio again and joined the download queue, might that have deleted it?)
Attachments
a.log
game log from T0 to crash
(246.4 KiB) Downloaded 70 times

EraYaN
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sun Sep 16, 2018 7:16 am
Contact:

Re: [0.17.32] Crash when connecting to server in stress test

Post by EraYaN »

I'll attach mine too. This was during the "Catching up" phase.
Attachments
Factorio_MMO_Test_crash.zip
(216.1 KiB) Downloaded 71 times

luc
Fast Inserter
Fast Inserter
Posts: 218
Joined: Sun Jul 17, 2016 9:53 pm
Contact:

Re: [0.17.32] Crash when connecting to server in stress test

Post by luc »

Thanks EraYaN, good to hear I'm not the only one!


Oxyd
Former Staff
Former Staff
Posts: 1428
Joined: Thu May 07, 2015 8:42 am
Contact:

Re: [0.17.32] Crash when connecting to server (InputActionDefragmenter::assemble)

Post by Oxyd »

Thanks, fixed in 0.17.37.

Post Reply

Return to “Resolved Problems and Bugs”