[Dominik][0.17.22] Game Crash after placing Big Electric Pole

This subforum contains all the issues which we already resolved.
Post Reply
toxic_avocado
Manual Inserter
Manual Inserter
Posts: 3
Joined: Fri Mar 29, 2019 1:43 pm
Contact:

[Dominik][0.17.22] Game Crash after placing Big Electric Pole

Post by toxic_avocado »

Was running and placing the big electric pole then the game just froze and crashed (log file below)
factorio-current.log
(551.39 KiB) Downloaded 154 times

thingsyourollup
Manual Inserter
Manual Inserter
Posts: 3
Joined: Fri Mar 29, 2019 1:49 pm
Contact:

Re: Game Crash after placing Big Electric Pole [0.17.22]

Post by thingsyourollup »

This is also occurring for me since the latest update. Happens when dragging large power poles and you happen to drag over an object.
Attachments
factorio-current.log
(141.76 KiB) Downloaded 104 times

frostig
Burner Inserter
Burner Inserter
Posts: 15
Joined: Mon Apr 24, 2017 4:48 pm
Contact:

Re: [Dominik][0.17.22] Game Crash after placing Big Electric Pole

Post by frostig »

same. i tried to replicate it and restarted the game twice so now sadly the log is lost...

User avatar
glek
Burner Inserter
Burner Inserter
Posts: 13
Joined: Wed Dec 30, 2015 11:54 pm
Contact:

Re: [Dominik][0.17.22] Game Crash after placing Big Electric Pole

Post by glek »

Seeing the same crash as of this morning.

Log file in case it helps:
Attachments
factorio-previous.log
(141.45 KiB) Downloaded 77 times
Programming is a way of life!

Yalee
Manual Inserter
Manual Inserter
Posts: 3
Joined: Tue Feb 26, 2019 6:38 pm
Contact:

Re: [Dominik][0.17.22] Game Crash after placing Big Electric Pole

Post by Yalee »

Same thing happens with me.

Tested on different save files and locations.

From my testing i assume it comes from going over the same valid placement option again in a different direction.

Also leaving your building reach and entering it again seems to trigger it also.
Also dragging from an existing big pole to a free spaces triggers the error too.

Or just leaving your building reach after going in circles in your building reach.

Just a lot of ways to trigger it i guess ^^"

Reproductionrate is 100%
Attachments
factorio-current.log
(141.04 KiB) Downloaded 78 times
factorio-current.log
(4.01 KiB) Downloaded 91 times

Dominik
Former Staff
Former Staff
Posts: 658
Joined: Sat Oct 12, 2013 9:08 am
Contact:

Re: [Dominik][0.17.22] Game Crash after placing Big Electric Pole

Post by Dominik »

Hi, sorry about that. Fix will come soon. Thanks for the help.

wsadjkljkl
Manual Inserter
Manual Inserter
Posts: 1
Joined: Fri Mar 29, 2019 3:32 pm
Contact:

Re: [Dominik][0.17.22] Game Crash after placing Big Electric Pole

Post by wsadjkljkl »

toxic_avocado wrote:
Fri Mar 29, 2019 1:45 pm
Was running and placing the big electric pole then the game just froze and crashed (log file below)
Same problem.
Attachments
factorio-current.log
(140.88 KiB) Downloaded 91 times

GrumpyJoe
Filter Inserter
Filter Inserter
Posts: 440
Joined: Fri Apr 06, 2018 7:10 pm
Contact:

Re: [Dominik][0.17.22] Game Crash after placing Big Electric Pole

Post by GrumpyJoe »

Dominik wrote:
Fri Mar 29, 2019 2:54 pm
Hi, sorry about that. Fix will come soon. Thanks for the help.
Since I only see reports for large poles here, is this also fixed for substations (yes, im that rich :D ) ? Dont wanna open anther report if it was a fix for the whole power pole class

dajoko
Manual Inserter
Manual Inserter
Posts: 1
Joined: Fri Mar 29, 2019 9:27 pm
Contact:

Re: [Dominik][0.17.22] Game Crash after placing Big Electric Pole

Post by dajoko »

substations .... happening to me too.

rockaday
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Mar 30, 2019 6:16 pm
Contact:

Re: [Dominik][0.17.22] Game Crash after placing Big Electric Pole

Post by rockaday »

Same. Here's my log file.
Attachments
factorio-current.log
(141.03 KiB) Downloaded 75 times

Dominik
Former Staff
Former Staff
Posts: 658
Joined: Sat Oct 12, 2013 9:08 am
Contact:

Re: [Dominik][0.17.22] Game Crash after placing Big Electric Pole

Post by Dominik »

Thanks but as you can see it is already in the resolved category. The fix is in 0.17.23.

Post Reply

Return to “Resolved Problems and Bugs”