[kovarex] [0.17.21] - Crash within ~22s of loading vanilla save file

This subforum contains all the issues which we already resolved.
Post Reply
akraziatic
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Mar 27, 2019 9:42 pm
Contact:

[kovarex] [0.17.21] - Crash within ~22s of loading vanilla save file

Post by akraziatic » Wed Mar 27, 2019 10:04 pm

After updating to the latest experimental version, within ~22 seconds of loading the save, the game freezes unexpectedly. Have made 4 attempts where I changed my course of action and even stood still after loading the save, however the issue has been consistent.

Have loaded another save file and couldn't replicate the issue.

Not sure if it has any bearing, but in the problematic save I had recently put a large number of belts down, triggering ~300 construction robots and ~200 logistics bots.

Was having trouble uploading the save file so here is a dropbox link: https://www.dropbox.com/s/b06qo0fv2i7h3cb/V5.zip?dl=0
Attachments
factorio-current.log
(7.56 KiB) Downloaded 15 times

User avatar
TruePikachu
Filter Inserter
Filter Inserter
Posts: 865
Joined: Sat Apr 09, 2016 8:39 pm
Contact:

Re: [0.17.21] - Crash within ~22s of loading vanilla save file

Post by TruePikachu » Wed Mar 27, 2019 10:59 pm

Code: Select all

Factorio crashed. Generating symbolized stacktrace, please wait ...
c:\cygwin64\tmp\factorio-build-s2gn0v\libraries\stackwalker\stackwalker.cpp (924): StackWalker::ShowCallstack
c:\cygwin64\tmp\factorio-build-s2gn0v\src\util\logger.cpp (376): Logger::writeStacktrace
c:\cygwin64\tmp\factorio-build-s2gn0v\src\util\logger.cpp (527): Logger::logStacktrace
c:\cygwin64\tmp\factorio-build-s2gn0v\src\util\logging.cpp (90): Logging::logAndAbortOrThrow
c:\cygwin64\tmp\factorio-build-s2gn0v\src\util\logging.cpp (84): Logging::logAndAbortOrThrow
c:\cygwin64\tmp\factorio-build-s2gn0v\src\entity\rollingstock.cpp (91): RollingStock::snapRollingStockOnSetup
c:\cygwin64\tmp\factorio-build-s2gn0v\src\entity\locomotive.cpp (343): Locomotive::snapRollingStockOnSetup
c:\cygwin64\tmp\factorio-build-s2gn0v\src\entity\rollingstock.cpp (67): RollingStock::setup
c:\cygwin64\tmp\factorio-build-s2gn0v\src\entity\locomotive.cpp (332): Locomotive::setup
c:\cygwin64\tmp\factorio-build-s2gn0v\src\entity\entityghost.cpp (414): EntityGhost::revive
c:\cygwin64\tmp\factorio-build-s2gn0v\src\entity\constructionrobot.cpp (625): ConstructionRobot::update
c:\cygwin64\tmp\factorio-build-s2gn0v\src\surface\chunk.cpp (567): Chunk::updateActiveEntities
c:\cygwin64\tmp\factorio-build-s2gn0v\src\surface\chunk.cpp (616): Chunk::updateEntities
c:\cygwin64\tmp\factorio-build-s2gn0v\src\surface\surface.cpp (1366): Surface::update
c:\cygwin64\tmp\factorio-build-s2gn0v\src\map\map.cpp (1459): Map::updateEntities
c:\cygwin64\tmp\factorio-build-s2gn0v\src\game.cpp (191): Game::update
c:\cygwin64\tmp\factorio-build-s2gn0v\src\scenario\scenario.cpp (1163): Scenario::update
c:\cygwin64\tmp\factorio-build-s2gn0v\src\mainloop.cpp (1114): MainLoop::gameUpdateStep
c:\cygwin64\tmp\factorio-build-s2gn0v\src\mainloop.cpp (980): MainLoop::gameUpdateLoop
c:\cygwin64\tmp\factorio-build-s2gn0v\src\util\workerthread.cpp (42): WorkerThread::loop
c:\program files (x86)\microsoft visual studio\2017\buildtools\vc\tools\msvc\14.15.26726\include\thr\xthread (230): std::_LaunchPad<std::unique_ptr<std::tuple<void (__cdecl RouterBase::*)(void),ClientRouter *>,std::default_delete<std::tuple<void (__cdecl RouterBase::*)(void),ClientRouter *> > > >::_Go
c:\program files (x86)\microsoft visual studio\2017\buildtools\vc\tools\msvc\14.15.26726\include\thr\xthread (209): std::_Pad::_Call_func
minkernel\crts\ucrt\src\appcrt\startup\thread.cpp (115): thread_start<unsigned int (__cdecl*)(void * __ptr64)>
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FF977D081F4)
00007FF977D081F4 (KERNEL32): (filename not available): BaseThreadInitThunk
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FF97A61A251)
00007FF97A61A251 (ntdll): (filename not available): RtlUserThreadStart
Stack trace logging done
  42.279 Error RollingStock.cpp:1033: Couldn't find the back joint rail.

akraziatic
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Mar 27, 2019 9:42 pm
Contact:

Re: [0.17.21] - Crash within ~22s of loading vanilla save file

Post by akraziatic » Mon Apr 01, 2019 3:45 am

Rolled back to [0.17.18] as it was the last version that I experienced no issues. After loading up an older autosave and starting again have come across another crash.

Link to save file: https://www.dropbox.com/s/sux7i7wn0z38p ... l.zip?dl=0


-------
EDIT: In case it has any bearing, the original is a save file I copied over onto my PC from a Mac.
Attachments
factorio-current.log
(7.68 KiB) Downloaded 11 times

User avatar
TruePikachu
Filter Inserter
Filter Inserter
Posts: 865
Joined: Sat Apr 09, 2016 8:39 pm
Contact:

Re: [0.17.21] - Crash within ~22s of loading vanilla save file

Post by TruePikachu » Mon Apr 01, 2019 4:32 am

Crash is from the same cause. Without checking anything other than the log, my guess is that there's a locomotive ghost somewhere that's trying to be built, but there's no track at the back end, causing the game to crash when it discovers that fact.

akraziatic
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Mar 27, 2019 9:42 pm
Contact:

Re: [0.17.21] - Crash within ~22s of loading vanilla save file

Post by akraziatic » Mon Apr 01, 2019 5:13 am

Thanks mate, I'll take a look. Could be the case as I'm beginning to build out my stackers.

akraziatic
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Mar 27, 2019 9:42 pm
Contact:

Re: [0.17.21] - Crash within ~22s of loading vanilla save file

Post by akraziatic » Mon Apr 01, 2019 5:14 am

Just found the train ghost. Will report back in ~30 minutes if no crash.

akraziatic
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Mar 27, 2019 9:42 pm
Contact:

Re: [0.17.21] - Crash within ~22s of loading vanilla save file

Post by akraziatic » Mon Apr 01, 2019 6:03 am

That appears to have done the trick. Should I close the bug now? Or will this be relevant for the devs?

tehfreek
Filter Inserter
Filter Inserter
Posts: 391
Joined: Thu Mar 17, 2016 7:34 am
Contact:

Re: [0.17.21] - Crash within ~22s of loading vanilla save file

Post by tehfreek » Mon Apr 01, 2019 11:04 am

It shouldn't be crashing regardless, so I say leave it.

kovarex
Factorio Staff
Factorio Staff
Posts: 7422
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.21] - Crash within ~22s of loading vanilla save file

Post by kovarex » Wed Apr 10, 2019 2:30 pm

Thanks for the report. seeing the place where it crashed made it super clear what is going on :).

The ghost managed to connect the front and back wheel to the rail, but there wasn't path between. This couldn't happen before train ghost building, but could happen now. I'm surprised, that this didn't happen more often.

Fixed for the next version.
Attachments
crash_spot.png
crash_spot.png (1.55 MiB) Viewed 2165 times

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users