[Twinsen][0.17.17] Slider in constant combinator skips 1

This subforum contains all the issues which we already resolved.
Post Reply
dirtcrusher
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sun Nov 29, 2015 1:30 pm
Contact:

[Twinsen][0.17.17] Slider in constant combinator skips 1

Post by dirtcrusher »

When modifying a value in a constant combinator using the slider, the value of 1 is skipped.
This happens when using the mouse to drag the slider, or by using the scroll wheel when hovering over the slider.

It can be reproduced easily in a clean vanilla save with the following steps:
  1. Place down constant combinator
  2. Add any signal
  3. Hover over the value slider and scroll down to make the signal 0, then scroll up one tick.
    The value will be 2 instead of 1

tehfreek
Filter Inserter
Filter Inserter
Posts: 391
Joined: Thu Mar 17, 2016 7:34 am
Contact:

Re: [0.17.17] Slider in constant combinator skips 1

Post by tehfreek »

Confirmed. Additionally, the last two positions both give a value of 100k. This smells like an off-by-one error.

Rseding91
Factorio Staff
Factorio Staff
Posts: 12215
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.17] Slider in constant combinator skips 1

Post by Rseding91 »

I'm not sure if this is a bug or not. The slider just translates the slider horizontal position using a log scale to the result number. It doesn't care if any given number is possible as a result - it just runs the calculation and gives a number back every time the slider moves.
If you want to get ahold of me I'm almost always on Discord.

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2605
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: [0.17.17] Slider in constant combinator skips 1

Post by steinio »

One is the lonelyest number...
Image
Transport Belt Repair Man

View unread Posts

Twinsen
Factorio Staff
Factorio Staff
Posts: 1240
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [Twinsen][0.17.17] Slider in constant combinator skips 1

Post by Twinsen »

Fixed both issues in Version: 0.17.22.
Thanks.

Post Reply

Return to “Resolved Problems and Bugs”