[TOGoS] [0.17.15] Error with map-gen-settings.json

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
Cooldude2606
Long Handed Inserter
Long Handed Inserter
Posts: 84
Joined: Sat Sep 16, 2017 9:04 pm
Contact:

[TOGoS] [0.17.15] Error with map-gen-settings.json

Post by Cooldude2606 »

All within write_dir/data/map-settings.json
Within "_property_expression_names_comment" it says to "Leave it blank to get 'normal' terrain." however when I used "elevation": "" no water was generated at all on the map (including non in the starting area) after chaning it to "0_16-elevation" it then started placing water so I feel that they is either a bug with the config loader or that there has just been a mistake with the comment in the file.
Thank you for looking into this report, see below for full map gen settings.
map-gen-settings.json
--- Developer for Explosive Gaming factorio community. Find our code on GitHub. Please contact me via our Discord. ---

TOGoS
Former Staff
Former Staff
Posts: 85
Joined: Fri Jun 24, 2016 2:29 pm
Contact:

Re: [TOGoS] [0.17.15] Error with map-gen-settings.json

Post by TOGoS »

Hmm, sounds like a bug.

For now, try removing the key/value "elevation" pair altogether.

TOGoS
Former Staff
Former Staff
Posts: 85
Joined: Fri Jun 24, 2016 2:29 pm
Contact:

Re: [TOGoS] [0.17.15] Error with map-gen-settings.json

Post by TOGoS »

Next release will treat empty expression names the same as lack of an entry, meaning 'use the default'. Thanks for the report!

Post Reply

Return to “Resolved Problems and Bugs”