[0.17.14] Changing from Team 1 to Team 1 in PvP kills player

This subforum contains all the issues which we already resolved.
Post Reply
Llama
Inserter
Inserter
Posts: 31
Joined: Tue Mar 01, 2016 1:50 am
Contact:

[0.17.14] Changing from Team 1 to Team 1 in PvP kills player

Post by Llama »

Changing from Team 1 to Team 1 in PvP kills player.

What did you do?
While navigating the Admin menu in a PvP game I clicked on Change Team to see what teams were available as I had been trying to create a 3rd team. There was no 3rd team so I wanted to close the menu, but with no Cancel or Back button visible I decided to join my own team to close the menu.

What happened?
I suddenly found myself in a different location without any items. Apparently it killed me which I did not expect, nor did it tell me I'd been killed.

What did you expect to happen instead?
I expected the menu to close without killing or relocating the player, as there was no change going from Team 1 to Team 1. It also highlighted that it would help if there was a cancel button in the Change Team menu (I did later discover that clicking Change Team menu again in the corner would close it, but it was too late and not obvious, I already tried clicking the Admin menu, pressing Esc, opening inventory to replace the window)

Steps to reproduce:
  • Host PvP scenario
  • LMB click Admin menu in the top left
  • LMB click Change Team
  • LMB click Join for team you are already on
  • Die
It happened 2 out of 2 times

JimAndy017_aa.zip save file attached for reproduction
Attachments
click admin, change team
click admin, change team
factorio_2019_03_18_17_50_55_059.jpg (427.55 KiB) Viewed 1156 times
join same team
join same team
factorio_2019_03_18_17_51_23_806.jpg (561.77 KiB) Viewed 1156 times
JimAndy017_aa.zip
save file
(11.82 MiB) Downloaded 27 times
ded
ded
factorio_2019_03_18_17_51_32_611.jpg (606.95 KiB) Viewed 1156 times

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 4407
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [0.17.14] Changing from Team 1 to Team 1 in PvP kills player

Post by Klonan »

Not really a bug, but I fixed it, as I see that its a bit rubbish

So, fixed for the next release

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users