[0.17.11]API: take_screenshot exception

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
aspd199
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri Jul 14, 2017 10:10 pm
Contact:

[0.17.11]API: take_screenshot exception

Post by aspd199 »

I upgraded the MOD to 0.17
But found the problem when generating the screenshot

api: take_screenshot

anti_alias is false : normal
anti_alias is true : exception

------------------------------------------------------
The three normal jpg anti_alias are false
s1 .png
s1 .png (146.4 KiB) Viewed 1478 times

User avatar
wheybags
Former Staff
Former Staff
Posts: 328
Joined: Fri Jun 02, 2017 1:50 pm
Contact:

Re: [0.17.11]API: take_screenshot exception

Post by wheybags »

Could you please post your error log?
https://wiki.factorio.com/Log_file

User avatar
aspd199
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri Jul 14, 2017 10:10 pm
Contact:

Re: [0.17.11]API: take_screenshot exception

Post by aspd199 »

wheybags wrote:
Thu Mar 14, 2019 4:28 pm
Could you please post your error log?
https://wiki.factorio.com/Log_file
Log file not error record, just the JPG generated by the API is incomplete.

/c game.take_screenshot{anti_alias=true}
factorio-current.log
(6.57 KiB) Downloaded 75 times

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.11]API: take_screenshot exception

Post by posila »

Thanks for the report.
Fixed for 0.17.13

Post Reply

Return to “Resolved Problems and Bugs”