[0.17.11] Changing 'Toggle menu' keybinding in controls settings is broken

This subforum contains all the issues which we already resolved.
Post Reply
dtip
Manual Inserter
Manual Inserter
Posts: 2
Joined: Tue Mar 12, 2019 11:56 am
Contact:

[0.17.11] Changing 'Toggle menu' keybinding in controls settings is broken

Post by dtip » Tue Mar 12, 2019 1:28 pm

Background

I remap CAPS to ESC on my machine (Linux 64) at the OS level and then use CAPS in-game to open and close the menu in 0.16. FFF #259 says we use scancodes instead of keycodes in 0.17, which means I have to change the 'toggle menu' keybinding in order to continue to use CAPS as ESC. Unfortunately it doesn't work perfectly.

The problem happens when I change the keybinding to any key other than ESC so I think this is a controls settings bug rather than a key binding issue as discussed here: viewtopic.php?f=7&t=65881.

What did you do?

Went into 'Settings -> Controls' (from either the main menu or in-game) and changed 'Toggle menu' from ESCAPE (ESC key) to ESCAPE (CAPS key).

I also tried changing 'Toggle menu' to a non-ESCAPE key (E in this case) and adding an additional 'Toggle menu' keybinding. The result was the same every time.

What happened?

Pressing CAPS at 'Settings' menu doesn't go back to main menu. Pressing CAPS at in-game menu doesn't close the menu and un-pause the game. Pressing CAPS in any of the 'Settings' sub-menus (Graphics, Controls, Sounds, Interface, Other, Mod settings) DOES go back to the 'Settings' menu. Pressing CAPS in-game DOES pause the game and open the menu.

What did you expect to happen instead?

I expected the new keybinding to function the same as the original binding: it should be possible to use it to fully exit out from the menu (both the startup menu and in-game).



This related post (viewtopic.php?t=53595) also reports the issue but it looks like nothing came of it. Rseding91 seems to say that re-binding 'Toggle menu' from escape isn't allowed. If this is true then the option should be removed! Otherwise I'd be grateful if you could fix it.

N.B. The use of scancodes here is a bit bizarre because you use keycodes to display the keybindings! There's no way to tell if ESCAPE is the actual escape key or if it's the CAPS re-binding.

Log file:

Code: Select all

   0.000 2019-03-12 12:55:33; Factorio 0.17.11 (build 43576, linux64, steam)
   0.053 Operating system: Linux (Ubuntu 18.10)
   0.053 Program arguments: "/home/dtip/.steam/steam/steamapps/common/Factorio/bin/x64/factorio" 
   0.053 Read data path: /home/dtip/.steam/steam/steamapps/common/Factorio/data
   0.053 Write data path: /home/dtip/.factorio [338658/466708MB]
   0.053 Binaries path: /home/dtip/.steam/steam/steamapps/common/Factorio/bin
   0.058 System info: [CPU:        Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz, 4 cores, RAM: 16023 MB]
   0.058 Environment: DISPLAY=:0, WAYLAND_DISPLAY=<unset>
   0.058 Display options: [FullScreen: 1] [VSync: 1] [UIScale: automatic (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.114 Available displays: 3
   0.114  [0]: HH221DPB 22" - {[3840,0], 1920x1080, SDL_PIXELFORMAT_RGB888, 60Hz}
   0.114  [1]: S240HL 24" - {[1920,0], 1920x1080, SDL_PIXELFORMAT_RGB888, 60Hz}
   0.114  [2]: S240HL 24" - {[0,0], 1920x1080, SDL_PIXELFORMAT_RGB888, 60Hz}
   0.140 Initialised OpenGL:[2] GeForce GTX 970/PCIe/SSE2; driver: 3.3.0 NVIDIA 410.78
   0.140   [Extensions] s3tc:yes; KHR_debug:yes; ARB_clear_texture:yes, ARB_copy_image:yes
   0.140   [Version] 3.3
   0.163 Graphics settings preset: very-high
   0.163   Dedicated video memory size 4096 MB
   0.163 Graphics options: [Graphics quality: high] [Video memory usage: all] [Light scale: 25%] [DXT: high-quality]
   0.163                   [Max load threads: 32] [Max texture size: 0] [Tex.Stream.: 0] [Rotation quality: normal] [Color: 32bit]
   0.216 Loading mod core 0.0.0 (data.lua)
   0.267 Loading mod base 0.17.11 (data.lua)
   0.412 Loading mod base 0.17.11 (data-updates.lua)
   0.483 Checksum for core: 4249075453
   0.483 Checksum of base: 46491745
   0.862 Loading sounds...
   0.881 Info PlayerData.cpp:69: Local player-data.json unavailable
   0.881 Info PlayerData.cpp:72: Cloud player-data.json available, timestamp 1552395061
   0.976 Initial atlas bitmap size is 16384
   0.997 Created atlas bitmap 16384x16380 [none]
   0.999 Created atlas bitmap 16384x11380 [none]
   0.999 Created atlas bitmap 16384x2116 [decal]
   1.000 Created atlas bitmap 16384x3808 [low-object]
   1.000 Created atlas bitmap 16384x1888 [mipmap, linear-minification, linear-magnification, linear-mip-level]
   1.001 Created atlas bitmap 16384x6880 [terrain, mipmap, linear-minification, linear-mip-level, no-crop]
   1.001 Created atlas bitmap 16384x480 [smoke, mipmap, linear-minification, linear-magnification]
   1.001 Created atlas bitmap 16384x456 [not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level, no-crop, no-scale]
   1.001 Created atlas bitmap 16384x748 [alpha-mask]
   1.003 Created atlas bitmap 16384x12644 [shadow, linear-magnification, alpha-mask]
   1.003 Created atlas bitmap 16384x1264 [shadow, mipmap, linear-magnification, alpha-mask]
   1.011 Texture processor created. GPU accelerated compression Supported: yes, Enabled: yes/yes. Test passed. YCoCgDXT PSNR: 35.83, BC3 PSNR: 33.82
   1.306 Parallel Sprite Loader initialized (threads: 3)
  16.757 Sprites loaded
  16.820 Generated mipmaps for atlas of size 16384x3808
  16.838 Generated mipmaps for atlas of size 16384x1888
  16.857 Generated mipmaps for atlas of size 16384x6880
  16.866 Generated mipmaps for atlas of size 16384x480
  16.880 Generated mipmaps for atlas of size 16384x456
  16.887 Generated mipmaps for atlas of size 16384x1264
  16.918 Custom inputs active: 6
  16.967 Factorio initialised
 554.879 Loading Level.dat: 999419 bytes.
 554.880 Info Scenario.cpp:147: Map version 0.17.11-0
 554.899 Checksum for script /home/dtip/.factorio/temp/currently-playing/control.lua: 1848333929
1678.163 Quitting: user-quit.
1678.164 Info GlobalContext.cpp:678: Waiting for child processes to exit: 
1678.283 Steam API shutdown.
1678.284 Goodbye

Twinsen
Factorio Staff
Factorio Staff
Posts: 847
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [0.17.11] Changing 'Toggle menu' keybinding in controls settings is broken

Post by Twinsen » Tue Mar 12, 2019 3:20 pm

I changed this behavior in Version: 0.17.12 so you can now close the menu.
But I might revert it if it causes other problems. Generally we don't fully support rebinding of ESC.

dtip
Manual Inserter
Manual Inserter
Posts: 2
Joined: Tue Mar 12, 2019 11:56 am
Contact:

Re: [0.17.11] Changing 'Toggle menu' keybinding in controls settings is broken

Post by dtip » Tue Mar 12, 2019 3:26 pm

Thanks!

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: skywardfire