[posila] [0.17.11] Vehicles and Radars show garbage graphics when zoomed out

This subforum contains all the issues which we already resolved.
Post Reply
gardrek
Burner Inserter
Burner Inserter
Posts: 16
Joined: Fri Mar 01, 2019 7:45 pm
Contact:

[posila] [0.17.11] Vehicles and Radars show garbage graphics when zoomed out

Post by gardrek »

Since updating to 0.17 all vehicles, radars, and some other graphics (see below) have shown garbage graphics when zoomed out far enough. Below is a link to a video of this in action. I am using an AMD A6-5400K APU with integrated Radeon HD Graphics on Linux, and I am using the stand-alone release, not Steam. In graphics settings, I have tried changing the atlas size and various quality selections, but no combination I've tried has seemed to have any effect on it. I had no problem like this on 0.16.51 so I suspect it has to do with the graphics rewrite.

Known Objects/Entities Affected:
* radars, locomotives, train wagons (but notably not the "opened" overlay when a cargo wagon is loading/unloading)
* cars and tanks (the kind you drive, not water tanks)
* the circuit network connectors that appear when you attach red or green wires to things

Video of the error:
https://imgur.com/ApFO99L
Apologies for the low quality; hopefully it is still demonstrative enough.
Attachments
factorio-current.log
(4.02 KiB) Downloaded 74 times

User avatar
TruePikachu
Filter Inserter
Filter Inserter
Posts: 978
Joined: Sat Apr 09, 2016 8:39 pm
Contact:

Re: [0.17.11] Vehicles and Radars show garbage graphics when zoomed out

Post by TruePikachu »

Do you get more garbage graphics if you reduce the VRAM usage setting from "high"?

gardrek
Burner Inserter
Burner Inserter
Posts: 16
Joined: Fri Mar 01, 2019 7:45 pm
Contact:

Re: [0.17.11] Vehicles and Radars show garbage graphics when zoomed out

Post by gardrek »

I just tried it, and yes! Changing "video memory usage" in graphics settings to "low" makes similar garbage also show for substations, roboports, and infinity chests, but not large power poles.

EDIT: loading another save I can see it affecting other things like assemblers, and trees

gardrek
Burner Inserter
Burner Inserter
Posts: 16
Joined: Fri Mar 01, 2019 7:45 pm
Contact:

Re: [0.17.11] Vehicles and Radars show garbage graphics when zoomed out

Post by gardrek »

Changing it to "All" seems to have fixed the problem. I really thought I had already tried that.

EDIT: Might be the combination of this and setting the texture atlas size up to 8192 instead of 4096

User avatar
TruePikachu
Filter Inserter
Filter Inserter
Posts: 978
Joined: Sat Apr 09, 2016 8:39 pm
Contact:

Re: [0.17.11] Vehicles and Radars show garbage graphics when zoomed out

Post by TruePikachu »

It would be the VRAM setting. What it actually does is choose which sprites remain in VRAM, and when it is "High" versus "All", it omits stuff like the radar, trains, cars, rocket silo...basically all the large sprites that have a _lot_ of animation frames.

The underlying issue would be something with transferring the not-staying-in-VRAM sprites to the GPU.

gardrek
Burner Inserter
Burner Inserter
Posts: 16
Joined: Fri Mar 01, 2019 7:45 pm
Contact:

Re: [0.17.11] Vehicles and Radars show garbage graphics when zoomed out

Post by gardrek »

That makes a lot of sense. Thanks for the troubleshooting help. Wish I had reported this bug sooner.

Vegemeister
Long Handed Inserter
Long Handed Inserter
Posts: 83
Joined: Sun Dec 04, 2016 9:18 pm
Contact:

Re: [0.17.11] Vehicles and Radars show garbage graphics when zoomed out

Post by Vegemeister »

The mouseover text suggests that the video memory usage setting affects the behavior of the "texture streaming" setting. Do you get the corruption with texture streaming off and video memory < all? On an integrated GPU, texture streaming off is probably the correct choice anyhow, since there's no point shuffling sprites between system ram and video RAM when your video RAM *is* system RAM.

gardrek
Burner Inserter
Burner Inserter
Posts: 16
Joined: Fri Mar 01, 2019 7:45 pm
Contact:

Re: [0.17.11] Vehicles and Radars show garbage graphics when zoomed out

Post by gardrek »

Vegemeister wrote:
Tue Mar 12, 2019 3:19 am
The mouseover text suggests that the video memory usage setting affects the behavior of the "texture streaming" setting. Do you get the corruption with texture streaming off and video memory < all? On an integrated GPU, texture streaming off is probably the correct choice anyhow, since there's no point shuffling sprites between system ram and video RAM when your video RAM *is* system RAM.
Sorry for the long delay. I completely forgot about this post. With texture streaming off and video memory set to "medium" I have no graphical errors.

posila
Factorio Staff
Factorio Staff
Posts: 5154
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.11] Vehicles and Radars show garbage graphics when zoomed out

Post by posila »

Thanks for the report, this should be fixed as of 0.17.26: 65466

Post Reply

Return to “Resolved Problems and Bugs”