[kovarex] [0.17.9] Trains leaving disabled stations due to rail signal placement

This subforum contains all the issues which we already resolved.
Post Reply
ARandomStone
Burner Inserter
Burner Inserter
Posts: 10
Joined: Thu Apr 13, 2017 12:09 pm
Contact:

[kovarex] [0.17.9] Trains leaving disabled stations due to rail signal placement

Post by ARandomStone » Sun Mar 10, 2019 7:54 pm

The Situation:
A train is in a disabled train station.

What i do:
Place/Remove a rail signal somewhere behind the train.

What should happen:
Nothing.

What does happen:
The train changes to not being in the station anymore and paths to another station with the same name.

Screenshots:
The first station is disabled, the second one enabled. The pic shows the situation before and after the leftmost signal is placed.
https://imgur.com/a/MvglqB3

knightelite
Long Handed Inserter
Long Handed Inserter
Posts: 88
Joined: Fri Oct 05, 2018 3:49 pm
Contact:

Re: [0.17.9] Trains leaving disabled stations due to rail signal placement

Post by knightelite » Mon Mar 11, 2019 4:44 am

Perhaps a variant of this one that didn't get fixed?

viewtopic.php?p=409929#p409929

kovarex
Factorio Staff
Factorio Staff
Posts: 7387
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.9] Trains leaving disabled stations due to rail signal placement

Post by kovarex » Tue Mar 12, 2019 11:09 am

Thanks for the report, fixed for 0.17.12

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: Google [Bot], IIPoliII