[posila] [0.17.9] FPS drop when zoomed in with many alt-mode icons (Intel)

This subforum contains all the issues which we already resolved.
Post Reply
JohnNy_cz
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Mar 09, 2019 11:50 pm
Contact:

[posila] [0.17.9] FPS drop when zoomed in with many alt-mode icons (Intel)

Post by JohnNy_cz »

Zooming in with alt-mode enabled in areas that have a lot of overlay icons leads to a huge FPS drop down to 12 FPS:
20190309225423_1.jpg
20190309225423_1.jpg (638.66 KiB) Viewed 3221 times
Same area, disabled alt-mode - 60 FPS:
20190309225431_1.jpg
20190309225431_1.jpg (662.92 KiB) Viewed 3221 times
Same area, zoomed out, alt-mode enabled - 60 FPS:
20190310004602_1.jpg
20190310004602_1.jpg (876.45 KiB) Viewed 3221 times
factorio-current.log:
factorio-current.log
(10.37 KiB) Downloaded 81 times
This started happening since 0.17, was working fine in 0.16. Note that my setup has Intel graphics card.

Graphics settings:
20190309130045_1.jpg
20190309130045_1.jpg (341.81 KiB) Viewed 3221 times

massa84
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Dec 13, 2017 11:10 pm
Contact:

Re: [0.17.9] FPS drop when zoomed in with many alt-mode icons (Intel)

Post by massa84 »

I have the same problem on my macbook pro, OsX 10.11, geforce 750M . The problem didn't present in any version of Factorio between 0.14 and 0.16

FPS drops from 60.0 to 20/30 fps when "alt mode" is enabled and I'm zoomed in.
In the debug console i see a huge increase of the "Flip[on]" timing that goes from the standard 13.666 ms (alt mode disabled or zoomed out) to 30.333 or 45

massa84
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Dec 13, 2017 11:10 pm
Contact:

Re: [posila] [0.17.9] FPS drop when zoomed in with many alt-mode icons (Intel)

Post by massa84 »

This issue is still present in the latest version (0.17.20).

I've also tried to toggle vsync with no avail.

It's interesting to notice that, at least for me it always drop to exactly 20 or exactly 30 fps.

JohnNy_cz
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Mar 09, 2019 11:50 pm
Contact:

Re: [posila] [0.17.9] FPS drop when zoomed in with many alt-mode icons (Intel)

Post by JohnNy_cz »

Anything I can try to work around this issue or any way I can help with fixing it?

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.9] FPS drop when zoomed in with many alt-mode icons (Intel)

Post by posila »

Thanks for the report.
This should be optimized in 0.17.30

JohnNy_cz
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Mar 09, 2019 11:50 pm
Contact:

Re: [posila] [0.17.9] FPS drop when zoomed in with many alt-mode icons (Intel)

Post by JohnNy_cz »

Works! Thank you!

Post Reply

Return to “Resolved Problems and Bugs”