[0.17.7][keybind] Open console mapped to key "0" on Hungarian keyboard

This subforum contains all the issues which we already resolved.
Post Reply
gyorokpeter
Inserter
Inserter
Posts: 29
Joined: Sat Jul 23, 2016 5:53 am
Contact:

[0.17.7][keybind] Open console mapped to key "0" on Hungarian keyboard

Post by gyorokpeter »

By default the Lua console is mapped to the number 0. This might have something to do with the fact that on the Hungarian keyboard the "0" key is to the left of 1, rather than to the right of 9.

The result of this is that whenever I want to type a zero (e.g. in a circuit condition) it brings up the console rather than typing a zero. I can reassign the key but it would be worth investigating whether there could be a more sensible default.
Attachments
controls.png
controls.png (1.23 MiB) Viewed 1660 times

Bilka
Factorio Staff
Factorio Staff
Posts: 2853
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: [0.17.7] Lua console mapped to key "0" on Hungarian keyboard

Post by Bilka »

The console default is also bad on German keyboards: It's on ^ which causes the key to show up in the console every time you start typing, it's infuriating.

Bug report on this behavior: 57219
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.7][keybind] Open console mapped to key "0" on Hungarian keyboard

Post by posila »

Thanks for the report.
Fixes for 65881 should make the behavior more reasonable (ie. 0 won't open console if text box is selected), so I hope it resolves the issue; I would like to avoid special default keybindings for different layouts as much as possible.

boran_blok
Long Handed Inserter
Long Handed Inserter
Posts: 93
Joined: Fri Mar 01, 2019 7:56 am
Contact:

Re: [0.17.7][keybind] Open console mapped to key "0" on Hungarian keyboard

Post by boran_blok »

This is for .16, I will test for .17 as well, but I use US international keyboard layout, this has dead keys (keys that register, and then act on the next key you type)

When I use the tilde, quote key (usually used to type ñ and ò for example) they keep registered and when I start typing it ends up as first, so most of my chat messages start with `

I will try and see if this also happens in .17 this afternoon.

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.7][keybind] Open console mapped to key "0" on Hungarian keyboard

Post by posila »

boran_blok wrote:
Tue Apr 16, 2019 7:59 am
I will try and see if this also happens in .17 this afternoon.
It does. That's what Bilka was reporting. But, dead keys is not what this report was about.

Post Reply

Return to “Resolved Problems and Bugs”