[0.17] [macos] FPS Performance issues

This subforum contains all the issues which we already resolved.
Post Reply
Kelebros
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sat Mar 02, 2019 10:36 pm
Contact:

[0.17] [macos] FPS Performance issues

Post by Kelebros » Thu Mar 07, 2019 12:15 am

Ever since 0.17 dropped I've had FPS performance issues. I've tried lowering all the graphics settings and nothing seems to make any difference.
I was consistently getting 60 FPS/UPS on 0.16 with default settings. I'm only getting 40-50 FPS reliably in an unmodded fresh game. I'm not having any issues with UPS only FPS. I'm on a Macbook Pro 15" retina mid-2014 with 16Gb RAM, quad-core 2.5 Ghz Core i7, and NVIDIA GT 750M 2Gb VRAM.
Logs and SS attached with requested debug options enabled, and no mods.

Edit

Also forgot to add that I'm running macos 10.14.3 Mojave
Attachments
Fullscreen_3_6_19__10_11_AM.jpg
Fullscreen_3_6_19__10_11_AM.jpg (4.19 MiB) Viewed 335 times
factorio-previous.log
(3.59 KiB) Downloaded 9 times
factorio-current.log
(3.59 KiB) Downloaded 8 times

posila
Factorio Staff
Factorio Staff
Posts: 3774
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17] [macos] FPS Performance issues

Post by posila » Wed Mar 13, 2019 2:28 pm

Thanks for the report.
In 0.17.12 there will be graphics option "Render in native screen resolution"; if you disable it and restart the game, the game won't be rendered in native Retina resolution anymore, which is how 0.16 behaved; it should greatly improve rendering performance for you.

Related report: 66870

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users