[antron] [0.17.5] [MacOS] Apple's "Magic Mouse" Horizontal Swipe Gesture Not Working In Technology Tree

This subforum contains all the issues which we already resolved.
Post Reply
schloss
Burner Inserter
Burner Inserter
Posts: 9
Joined: Fri Feb 22, 2019 3:16 pm
Contact:

[antron] [0.17.5] [MacOS] Apple's "Magic Mouse" Horizontal Swipe Gesture Not Working In Technology Tree

Post by schloss »

Minor issue:

I'm using a first-generation magic mouse in OS 10.10.5 (Yosemite).
When I come across a recipe that opens up a lot of new tech in which scrollbars show up in the technology tree, I can use the vertical swipe gesture to successfully scroll vertically. However, a horizontal scroll gesture will not scroll the window horizontally.
Attachments
scroll.jpg
scroll.jpg (379.13 KiB) Viewed 4802 times

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [antron] [0.17.5] [MacOS] Apple's "Magic Mouse" Horizontal Swipe Gesture Not Working In Technology Tree

Post by posila »

Thanks for the report.
Fixed in 0.17.15

schloss
Burner Inserter
Burner Inserter
Posts: 9
Joined: Fri Feb 22, 2019 3:16 pm
Contact:

Re: [antron] [0.17.5] [MacOS] Apple's "Magic Mouse" Horizontal Swipe Gesture Not Working In Technology Tree

Post by schloss »

Thanks for the efforts but horizontal scrolling still not working with Apple's Magic Mouse.

antron
Burner Inserter
Burner Inserter
Posts: 7
Joined: Tue Mar 05, 2019 5:10 pm
Contact:

Re: [antron] [0.17.5] [MacOS] Apple's "Magic Mouse" Horizontal Swipe Gesture Not Working In Technology Tree

Post by antron »

One possible explanation is that Factorio's horizontal scrolling speed is so slow that a horizontal scroll did not register or was not visible (we may have to increase it, it is *much* slower than vertical scroll). I just tried again with 0.17.15 and a Magic Mouse, and horizontal scrolling seems to be working. Would you mind giving it another look, and trying a really big scroll?

schloss
Burner Inserter
Burner Inserter
Posts: 9
Joined: Fri Feb 22, 2019 3:16 pm
Contact:

Re: [antron] [0.17.5] [MacOS] Apple's "Magic Mouse" Horizontal Swipe Gesture Not Working In Technology Tree

Post by schloss »

Ah yes. I see the scrolling now. I think what may have happened is the mouse lost its bluetooth connection just as I was testing. I just put some new batteries in the magic mouse and restarted Factorio 0.17.15 and it is indeed fixed. But yes, the scroll speed is very, very slow.
Apologies for the wild goose chase there.

antron
Burner Inserter
Burner Inserter
Posts: 7
Joined: Tue Mar 05, 2019 5:10 pm
Contact:

Re: [antron] [0.17.5] [MacOS] Apple's "Magic Mouse" Horizontal Swipe Gesture Not Working In Technology Tree

Post by antron »

Great, thank you!

On the contrary, rather than a goose chase, it's good positive confirmation the fix is real :) I've added myself a note to look at the scroll speed soon.

Post Reply

Return to “Resolved Problems and Bugs”