[Rseding91] [0.17] Mod bool settings change randomly

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
Optera
Smart Inserter
Smart Inserter
Posts: 2347
Joined: Sat Jun 11, 2016 6:41 am
Contact:

[Rseding91] [0.17] Mod bool settings change randomly

Post by Optera »

Since 0.17 went up I keep getting reports of LTN map settings being toggled on or off from updating other mods.
viewtopic.php?f=214&t=65863#p403644
https://github.com/Yousei9/Logistic-Tra ... issues/156

All cases where bool settings being switched to the opposite state of their default.
I couldn't get these effects to happen for myself and double checked to use my mod settings as read only.

Are there other reports of mod settings being randomly set?

Did I do something wrong reading mod settings the way it always worked in 0.16?
https://github.com/Yousei9/Logistic-Tra ... ace.lua#L1

Rseding91
Factorio Staff
Factorio Staff
Posts: 10163
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17] Mod bool settings change randomly

Post by Rseding91 »

I don't know of anything that would cause a mod setting to change without a player specifically changing it.

If you find any steps to reproduce the problem I can look into it but until then there's nothing I can do.
If you want to get ahold of me I'm almost always on Discord.

IronCartographer
Filter Inserter
Filter Inserter
Posts: 359
Joined: Tue Jun 28, 2016 2:07 pm
Contact:

Re: [0.17] Mod bool settings change randomly

Post by IronCartographer »

I've experienced this and had numerous reports confirming it on Discord.

Some settings radically change gameplay unexpectedly so this issue is significant.

Hopefully someone can find a test case soon.
Rseding91 wrote:
Wed Mar 06, 2019 12:36 pm
I don't know of anything that would cause a mod setting to change without a player specifically changing it.
The ability for lua to change settings in-game, combined with the new per-save settings option, suggest surface area for something getting bumped.

EnigmaticAussie
Fast Inserter
Fast Inserter
Posts: 116
Joined: Mon Dec 18, 2017 7:53 am
Contact:

Re: [0.17] Mod bool settings change randomly

Post by EnigmaticAussie »

I have a reproducible test.

It affects the settings for bottleneck, changing the colors of the dots from the default.

Performing a full sync of mods with the attached save file should make bottleneck display with red, yellow and green dots. *
Image
Enabling minable-intermediates_0.17.4 version (attached), changes the display dots to red, red, yellow. (Testing the same save with 0.17.5 of the mi mod makes no changes to the bottleneck settings).
Image


*The sync is important. To fully reproduce the changes, the sync *must* be performed, the game restarted, and then minable-intermediates_0.17.4 enabled.
Attachments
minable-intermediates_0.17.4.zip
(55.51 KiB) Downloaded 19 times
0.17.4-qol.zip
Save file
(6.98 MiB) Downloaded 22 times

IronCartographer
Filter Inserter
Filter Inserter
Posts: 359
Joined: Tue Jun 28, 2016 2:07 pm
Contact:

Re: [0.17] Mod bool settings change randomly

Post by IronCartographer »

Well, that's not just bools!

Interesting to note: The settings are fine upon restarting after enabling the additional mod (as viewed from the main menu), but incorrect when the save is loaded. The menu modded map settings remain unaffected.

Also: Taking a save with the mod enabled, then disabling it, results in the settings of the new save loading identically to those of the original save.

User avatar
Optera
Smart Inserter
Smart Inserter
Posts: 2347
Joined: Sat Jun 11, 2016 6:41 am
Contact:

Re: [0.17] Mod bool settings change randomly

Post by Optera »

It seems to happen more often to me now with 0.17.8.
Almost every time when I install or update a mod a random setting changes. Today Noxy's Trees looked almost as if the game tried to shift all their settings up by one index after adding a small mod with 2 settings.

Rseding91
Factorio Staff
Factorio Staff
Posts: 10163
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17] Mod bool settings change randomly

Post by Rseding91 »

I think I know what's going on. I'll look into it tomorrow and see if I can get it fixed.
If you want to get ahold of me I'm almost always on Discord.

Rseding91
Factorio Staff
Factorio Staff
Posts: 10163
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [0.17] Mod bool settings change randomly

Post by Rseding91 »

Ok, it's now fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

dgw
Fast Inserter
Fast Inserter
Posts: 190
Joined: Tue Apr 12, 2016 7:06 pm
Contact:

Re: [Rseding91] [0.17] Mod bool settings change randomly

Post by dgw »

That's great news. My Bottleneck colors got shuffled today (yesterday, in Wube-land) in 0.17.8, so I will eagerly await .9 tomorrow (later today, in Wube-land)!

Zaflis
Filter Inserter
Filter Inserter
Posts: 315
Joined: Sun Apr 24, 2016 12:51 am
Contact:

Re: [Rseding91] [0.17] Mod bool settings change randomly

Post by Zaflis »

Try to play bob's mods with god modules. Every time i add new mod or remove one, the modules turn themselves off. It's still happening in 0.17.9. I have to go to new game menu, turn them back on and restart game.

Also in the Other Settings i have "Use different mod settings per save" set Off. I mean, imprinting unchangeable settings into save file would be worst thing anyone would ever do...

Rseding91
Factorio Staff
Factorio Staff
Posts: 10163
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [0.17] Mod bool settings change randomly

Post by Rseding91 »

Zaflis wrote:
Sun Mar 10, 2019 8:57 pm
Try to play bob's mods with god modules. Every time i add new mod or remove one, the modules turn themselves off. It's still happening in 0.17.9. I have to go to new game menu, turn them back on and restart game.

Also in the Other Settings i have "Use different mod settings per save" set Off. I mean, imprinting unchangeable settings into save file would be worst thing anyone would ever do...
They're not unchangable. You can change them from in the save by loading the save, pressing escape and going into mod settings.

Also, you'll need to make a new report with steps to reproduce the issue.
If you want to get ahold of me I'm almost always on Discord.

Zaflis
Filter Inserter
Filter Inserter
Posts: 315
Joined: Sun Apr 24, 2016 12:51 am
Contact:

Re: [Rseding91] [0.17] Mod bool settings change randomly

Post by Zaflis »

Rseding91 wrote:
Mon Mar 11, 2019 1:42 pm
They're not unchangable. You can change them from in the save by loading the save, pressing escape and going into mod settings.

Also, you'll need to make a new report with steps to reproduce the issue.
The startup tab is grayed out when ingame. Yet i can change them too from the new game menu and it affects the save.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users