[Dominik][0.17.4][Mod] Crash when loading save with attempt at modded burner electricity generator

This subforum contains all the issues which we already resolved.
Post Reply
Emerassi
Burner Inserter
Burner Inserter
Posts: 6
Joined: Sun Mar 03, 2019 7:59 pm
Contact:

[Dominik][0.17.4][Mod] Crash when loading save with attempt at modded burner electricity generator

Post by Emerassi » Sun Mar 03, 2019 8:34 pm

I'm working on a mod. In that mod I have an entity that is supposed to take in fuel and burn it to create electricity. The entity is called mana-engine. I have a save that already had a mana-engine in it back when it was originally just a clone of the base game's steam engine. In order to get it to do what I wanted, I edited mana-engine to be a modified copy of the burner-generator from KS-Power and tried making changes. After those changes, the game will now crash when I attempt to load the save (3x crashes in a row, so it seems reliable). I've attached the mod, named Sorcerio and the map, named SorcerioTest. If, instead of loading the save, I make a new map (SorcerioTest2), I am able to place a mana-engine without problems. I am also able to load the new map (SorcerioTest2) without problems.
Attachments
SorcerioTest.zip
(3.4 MiB) Downloaded 15 times
Sorcerio_0.1.0.zip
(5.97 MiB) Downloaded 15 times
factorio-dump-current.dmp
(641.59 KiB) Downloaded 12 times
factorio-current.log
(8.68 KiB) Downloaded 13 times

Loewchen
Global Moderator
Global Moderator
Posts: 5185
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.17.04] Crash when loading save with attempt at modded burner electricity generator

Post by Loewchen » Sun Mar 03, 2019 8:40 pm

Code: Select all

   0.001 2019-03-03 12:02:11; Factorio 0.17.4 (build 43174, win64, steam)
   0.001 Operating system: Windows 10 (version 1803) 
   0.001 Program arguments: "C:\Steam\steamapps\common\Factorio\bin\x64\Factorio.exe" "--wait-to-close" "73048" 
   0.001 Read data path: C:/Steam/steamapps/common/Factorio/data
   0.001 Write data path: C:/Users/Zephyr/AppData/Roaming/Factorio [20478/228083MB]
   0.001 Binaries path: C:/Steam/steamapps/common/Factorio/bin
   0.026 System info: [CPU: Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz, 8 cores, RAM: 5625/8129 MB, page: 15560/22977 MB, virtual: 4331/134217727 MB, extended virtual: 0 MB]
   0.026 Display options: [FullScreen: 1] [VSync: 1] [UIScale: automatic (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.038 Available displays: 2
   0.038  [0]: \\.\DISPLAY1 - NVIDIA GeForce GTX 1060 6GB {0x05, [0,0], 1920x1080, 32bit, 60Hz}
   0.039  [1]: \\.\DISPLAY2 - NVIDIA GeForce GTX 1060 6GB {0x01, [-1920,0], 1920x1080, 32bit, 60Hz}
   0.118 Display: 0 -> Adapter: 0, Output: 0
   0.265 Initialised Direct3D[0]: NVIDIA GeForce GTX 1060 6GB; driver: nvldumdx.dll 24.21.13.9907
   0.265   D3D Feature Level: 11.1, DXGI 1.5+
   0.265   [Local Video Memory] Budget: 5144MB, CurrentUsage: 1MB, Reservation: 0/2723MB
   0.265   [Non-Local Vid.Mem.] Budget: 3658MB, CurrentUsage: 0MB, Reservation: 0/1930MB
   0.265   Tiled resources: Tier 2
   0.265   Unified Memory Architecture: No
   0.265   BGR 565 Supported: Yes
   0.265   MaximumFrameLatency: 3, GPUThreadPriority: 0
   0.349 Desktop composition is active.
   0.349 Graphics settings preset: very-high
   0.349   Dedicated video memory size 6052 MB
   0.349 Graphics options: [Graphics quality: high] [Video memory usage: high] [Light scale: 100%] [DXT: high-quality]
   0.349                   [Max load threads: 32] [Max texture size: 0] [Tex.Stream.: 1] [Low quality rotation: 0]
   0.470 DSound: Starting _dsound_update thread
   0.471 DSound: Enter _dsound_update; tid=73532
   1.028 Razer Chroma Controller initialized.
   1.247 Loading mod core 0.0.0 (data.lua)
   1.446 Loading mod base 0.17.4 (data.lua)
   2.318 Loading mod Sorcerio 0.1.0 (data.lua)
   2.578 Loading mod base 0.17.4 (data-updates.lua)
   2.782 Loading mod Sorcerio 0.1.0 (data-final-fixes.lua)
   2.964 Checksum for core: 3928040144
   2.964 Checksum of base: 60305742
   2.964 Checksum of Sorcerio: 3147330437
   2.964 Checksum of themightygugi_longreach: 0
   3.749 Loading sounds...
   7.077 Info PlayerData.cpp:69: Local player-data.json unavailable
   7.077 Info PlayerData.cpp:72: Cloud player-data.json available, timestamp 1551601024
   7.287 Initial atlas bitmap size is 16384
   7.322 Created atlas bitmap 16384x16376 [none]
   7.324 Created atlas bitmap 16384x4444 [none]
   7.324 Created atlas bitmap 16384x2116 [decal]
   7.326 Created atlas bitmap 16384x3808 [low-object]
   7.327 Created atlas bitmap 16384x1888 [mipmap, linear-minification, linear-magnification, linear-mip-level, no-crop, no-scale]
   7.329 Created atlas bitmap 16384x6592 [terrain, mipmap, linear-minification, linear-mip-level, no-crop]
   7.330 Created atlas bitmap 16384x480 [smoke, mipmap, linear-minification, linear-magnification]
   7.331 Created atlas bitmap 16384x456 [not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level, no-crop, no-scale]
   7.331 Created atlas bitmap 16384x748 [alpha-mask]
   7.335 Created atlas bitmap 16384x12632 [shadow, linear-magnification, alpha-mask]
   7.335 Created atlas bitmap 16384x1264 [shadow, mipmap, linear-magnification, alpha-mask]
   7.621 Created virtual atlas pages 4096x4096x7
   7.634 Texture processor created. GPU accelerated compression Supported: yes, Enabled: yes/yes. Test passed. YCoCgDXT PSNR: 35.83, BC3 PSNR: 33.82
  13.899 Parallel Sprite Loader initialized (threads: 5)
  26.587 Sprites loaded
  26.642 Generated mipmaps for atlas of size 16384x3808
  26.675 Generated mipmaps for atlas of size 16384x1888
  26.707 Generated mipmaps for atlas of size 16384x6592
  26.718 Generated mipmaps for atlas of size 16384x480
  26.729 Generated mipmaps for atlas of size 16384x456
  26.740 Generated mipmaps for atlas of size 16384x1264
  26.906 Generated mipmaps for virtual atlas of size 8192x16384
  26.923 Custom inputs active: 0
  27.091 Factorio initialised
 113.216 Loading map C:\Users\Zephyr\AppData\Roaming\Factorio\saves\SorcerioTest.zip: 3562019 bytes.
 113.361 Loading Level.dat: 4639970 bytes.
 113.365 Info Scenario.cpp:147: Map version 0.17.4-1
 113.520 Error CrashHandler.cpp:376: Exception Code: c0000005, Address: 0x00007ff64dcbf390
ModuleBase: 0x00007ff64da40000, ImageSize: 015ed000, RelativeAddress: 0027f390
 113.520 Error CrashHandler.cpp:382: Access Violation: Read at address 0000000000000058
 113.520 Error CrashHandler.cpp:396: Exception Context:
rax=000000956ffff108, rbx=00000277f96a4020, rcx=00000277f60ac7b0,
rdx=00000277f6b68fc0, rsi=0000000000000000, rdi=00000277f6b68fc0,
rip=00007ff64dcbf390, rsp=000000956ffff090, rbp=000000956ffff250,
 r8=00000277dc0c9601,  r9=0000000000008000, r10=000002781e370080,
r11=000000956fffee80, r12=00000277f174d300, r13=00000277f60ac7b0,
r14=0000027828a3c0f8, r15=000002781b30ecb0
 113.520 Crashed in C:\Steam\steamapps\common\Factorio\bin\x64\Factorio.exe (0x00007ff64da40000 - 0x00007ff64f02d000)
Factorio crashed. Generating symbolized stacktrace, please wait ...
c:\cygwin64\tmp\factorio-build-ocil06\libraries\stackwalker\stackwalker.cpp (924): StackWalker::ShowCallstack
c:\cygwin64\tmp\factorio-build-ocil06\src\util\logger.cpp (405): Logger::writeStacktrace
c:\cygwin64\tmp\factorio-build-ocil06\src\util\logger.cpp (515): Logger::logStacktrace
c:\cygwin64\tmp\factorio-build-ocil06\src\util\crashhandler.cpp (169): CrashHandler::writeStackTrace
c:\cygwin64\tmp\factorio-build-ocil06\src\util\crashhandler.cpp (423): CrashHandler::SehHandler
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFBED9EBDD0)
00007FFBED9EBDD0 (KERNELBASE): (filename not available): UnhandledExceptionFilter
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFBF1353167)
00007FFBF1353167 (ntdll): (filename not available): memset
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFBF133B5E6)
00007FFBF133B5E6 (ntdll): (filename not available): _C_specific_handler
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFBF134F7DD)
00007FFBF134F7DD (ntdll): (filename not available): _chkstk
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFBF12BD856)
00007FFBF12BD856 (ntdll): (filename not available): RtlWalkFrameChain
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFBF134E70E)
00007FFBF134E70E (ntdll): (filename not available): KiUserExceptionDispatcher
c:\cygwin64\tmp\factorio-build-ocil06\src\fluid\fluidmanager.cpp (212): FluidManager::moveOut
c:\cygwin64\tmp\factorio-build-ocil06\src\entity\generator.cpp (132): Generator::setup
c:\cygwin64\tmp\factorio-build-ocil06\src\map\map.cpp (806): Map::setupEntities
c:\cygwin64\tmp\factorio-build-ocil06\src\scenario\scenario.cpp (226): Scenario::loadFactory
c:\cygwin64\tmp\factorio-build-ocil06\src\scenario\parallelscenarioloader.cpp (155): ParallelScenarioLoader::doLoad
c:\program files (x86)\microsoft visual studio\2017\buildtools\vc\tools\msvc\14.15.26726\include\thr\xthread (230): std::_LaunchPad<std::unique_ptr<std::tuple<void (__cdecl*)(ParallelScenarioLoader *,MapDeserialiser *,enum InputType,InputHandler *,MultiplayerManagerBase *,bool),ParallelScenarioLoader *,MapDeserialiser *,enum InputType,InputHandler *,MultiplayerManagerBase *,bool>,std::default_delete<std::tuple<void (__cdecl*)(ParallelScenarioLoader *,MapDeserialiser *,enum InputType,InputHandler *,MultiplayerManagerBase *,bool),ParallelScenarioLoader *,MapDeserialiser *,enum InputType,InputHandler *,MultiplayerManagerBase *,bool> > > >::_Go
c:\program files (x86)\microsoft visual studio\2017\buildtools\vc\tools\msvc\14.15.26726\include\thr\xthread (209): std::_Pad::_Call_func
minkernel\crts\ucrt\src\appcrt\startup\thread.cpp (115): thread_start<unsigned int (__cdecl*)(void * __ptr64)>
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFBF0AE3DC4)
00007FFBF0AE3DC4 (KERNEL32): (filename not available): BaseThreadInitThunk
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFBF1323691)
00007FFBF1323691 (ntdll): (filename not available): RtlUserThreadStart
Stack trace logging done
 116.344 Error Util.cpp:97: Unexpected error occurred. If you're running the latest version of the game you can help us solve the problem by posting the contents of the log file on the Factorio forums.
Please also include the save file(s), any mods you may be using, and any steps you know of to reproduce the crash.
 119.909 Uploading log file
 119.924 Error CrashHandler.cpp:221: Heap validation: success.
 119.926 Creating crash dump.
 120.519 CrashDump success

Emerassi
Burner Inserter
Burner Inserter
Posts: 6
Joined: Sun Mar 03, 2019 7:59 pm
Contact:

Re: [Dominik][0.17.4][Mod] Crash when loading save with attempt at modded burner electricity generator

Post by Emerassi » Mon Mar 04, 2019 6:52 pm

Just want to let you know this still reproduces in 0.17.5 on my computer.

Dominik
Factorio Staff
Factorio Staff
Posts: 534
Joined: Sat Oct 12, 2013 9:08 am
Contact:

Re: [Dominik][0.17.4][Mod] Crash when loading save with attempt at modded burner electricity generator

Post by Dominik » Tue Mar 05, 2019 1:01 pm

Hi, can you provide the original save (0.16 I assume?)
This indeed fails but it is hard to find why. It can be similar issue as 66316
I see that there are no fluidboxes in the mana engine so that should not be the issue.

Emerassi
Burner Inserter
Burner Inserter
Posts: 6
Joined: Sun Mar 03, 2019 7:59 pm
Contact:

Re: [Dominik][0.17.4][Mod] Crash when loading save with attempt at modded burner electricity generator

Post by Emerassi » Tue Mar 05, 2019 7:39 pm

The original save was from 0.17.4 (I had been in the middle of the - edit mod, load save, test mod, optionally save, close factorio, repeat - cycle). All that changed was the definitions of the mod (mana-engine entity was defined like a steam-engine when the save was made, but the mod definition changed to make it behave like KS-Power's burner-generator). So it used to have fluidboxes when it was a steam-engine and then it stopped having them when I changed it to be a burner-generator. I can only assume it's modder error (aka I screwed up) but since it resulted in a crash instead of an error message, I didn't have the tools to self-correct and sent it your way. My mod worked fine after on a new save, but loading that old one caused a crash.

Dominik
Factorio Staff
Factorio Staff
Posts: 534
Joined: Sat Oct 12, 2013 9:08 am
Contact:

Re: [Dominik][0.17.4][Mod] Crash when loading save with attempt at modded burner electricity generator

Post by Dominik » Wed Mar 13, 2019 3:56 pm

It is fixed now. Another special case migration. Thanks!

Emerassi
Burner Inserter
Burner Inserter
Posts: 6
Joined: Sun Mar 03, 2019 7:59 pm
Contact:

Re: [Dominik][0.17.4][Mod] Crash when loading save with attempt at modded burner electricity generator

Post by Emerassi » Wed Mar 13, 2019 5:08 pm

Thanks for being awesome.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users