[Klonan] [0.17.3] Crash when loading 0.16 vanilla PvP

This subforum contains all the issues which we already resolved.
Post Reply
Queuebee
Burner Inserter
Burner Inserter
Posts: 17
Joined: Fri Mar 01, 2019 12:51 pm
Contact:

[Klonan] [0.17.3] Crash when loading 0.16 vanilla PvP

Post by Queuebee »

Not sure if I should open a new post for this, but I think I have (kinda?) the same issue.

I have an old 16.30 PvP map (vanilla, I'm pretty sure) that I downloaded to play solo. I can enter the old save, walk around, do things, but the pvp configuration menu stays and covers a big part of the screen (see screenshots in PvP_config_menu_bug.zip).

Sorry if I did something wrong here, this is only my 2nd post, let me know if I did.

Is there any other information I could provide?
Attachments
PvP_config_menu_bug.zip
multiple screenshots to show how I could access different interfaces, with the 'PvP configuration' menu still up (or under). I was able to play the game, but couldn't save (reliably, saves would crash)
(1.66 MiB) Downloaded 83 times
error that occurs when loading the map after saving it in 17.x
error that occurs when loading the map after saving it in 17.x
scenario crash PvP 16.30 in 17.x.png (35.16 KiB) Viewed 2155 times
error that occurs when clicking the 'start round' button.
error that occurs when clicking the 'start round' button.
save error when clicking start round.PNG (126.11 KiB) Viewed 2155 times

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 5030
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [Klonan] [0.17.3] Crash when loading 0.16 vanilla PvP

Post by Klonan »

Can you attach the save game?

Queuebee
Burner Inserter
Burner Inserter
Posts: 17
Joined: Fri Mar 01, 2019 12:51 pm
Contact:

Re: [Klonan] [0.17.3] Crash when loading 0.16 vanilla PvP

Post by Queuebee »

EDIT: I thought I got the file to upload, but I think it's too big (32mb)

I got

Error
Error parsing server response.


----------------------------------------------------------------------------------------------------

Here's the savefile, As of 17.5, it doesn't crash anymore, but the multiplayer configuration does stay up and I don't see a way to play it like I used to (just like a singleplayer map)
Last edited by Queuebee on Tue Mar 05, 2019 12:59 pm, edited 1 time in total.

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 5030
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [Klonan] [0.17.3] Crash when loading 0.16 vanilla PvP

Post by Klonan »

Queuebee wrote:
Tue Mar 05, 2019 12:58 pm
Here's the savefile
I don't see anything

Queuebee
Burner Inserter
Burner Inserter
Posts: 17
Joined: Fri Mar 01, 2019 12:51 pm
Contact:

Re: [Klonan] [0.17.3] Crash when loading 0.16 vanilla PvP

Post by Queuebee »

The file didn't upload correctly, are 32mb files allowed?

Queuebee
Burner Inserter
Burner Inserter
Posts: 17
Joined: Fri Mar 01, 2019 12:51 pm
Contact:

Re: [Klonan] [0.17.3] Crash when loading 0.16 vanilla PvP

Post by Queuebee »

I've uploaded it to google drive, here: https://drive.google.com/open?id=1K08td ... bAsNznN3Ti

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 5030
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [Klonan] [0.17.3] Crash when loading 0.16 vanilla PvP

Post by Klonan »

Can you provide the 0.16 version?


User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 5030
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [Klonan] [0.17.3] Crash when loading 0.16 vanilla PvP

Post by Klonan »

So, when you load the 0.16 map in 0.17 now it will migrate correctly.

The 0.17 map is not really able to be preserved, but I suppose you didn't play on it much if it had the GUI in the way.

Queuebee
Burner Inserter
Burner Inserter
Posts: 17
Joined: Fri Mar 01, 2019 12:51 pm
Contact:

Re: [Klonan] [0.17.3] Crash when loading 0.16 vanilla PvP

Post by Queuebee »

As of 17.8, The issue has been solved for me. The 16.x PvP map is properly converted.

Just to clarify on the issue I had, The configuration menu overlay wasn't there in 16.x, I was able to play the PvP map in singleplayer. It appeared when I tried to load it in 17.1 / 17.4 .

Thanks for the quick fix! Really appreciate it!

Post Reply

Return to “Resolved Problems and Bugs”