[kovarex] [0.17.4] Undo does not restore circuit connections

This subforum contains all the issues which we already resolved.
Post Reply
jmurrayufo
Inserter
Inserter
Posts: 29
Joined: Sat Jun 13, 2015 8:02 pm
Contact:

[kovarex] [0.17.4] Undo does not restore circuit connections

Post by jmurrayufo »

Problem: Pressing ctrl+z (Undo) after removing an entity with a circuit connection restores the item, but not the circuit connections it had (even though the other entities are still correctly placed).

Expected behavior: Undo should restore affected entities to their previous states.

Tested on: 0.17.4 with Combinators, Lamps and power poles in various configs. Hand removing items, cutting the item, or deconstruction seems to all effect Undo the same way.

I've attached a quick save to demo the bug as well.
Attachments
BugExample.zip
Example save file, should load without mods. Used creative mod to enable infinite items first for debug then removed mod.
(1.04 MiB) Downloaded 27 times

kovarex
Factorio Staff
Factorio Staff
Posts: 7448
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.4] Undo does not restore circuit connections

Post by kovarex »

Thanks for the report. It wasn't trivial to do, but undo will support circuit connections in 0.17.7

jmurrayufo
Inserter
Inserter
Posts: 29
Joined: Sat Jun 13, 2015 8:02 pm
Contact:

Re: [kovarex] [0.17.4] Undo does not restore circuit connections

Post by jmurrayufo »

Thanks for the fix! Ctrl+Z is a game changing feature for my clumsy game play, and this was the only part of it that I've found that didn't seem to work right.

You guys are awesome!


Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users