[0.17.4] Biters getting into massive clumps and lagging

This subforum contains all the issues which we already resolved.
Post Reply
bobby45800
Burner Inserter
Burner Inserter
Posts: 19
Joined: Sat Jan 23, 2016 10:46 am
Contact:

[0.17.4] Biters getting into massive clumps and lagging

Post by bobby45800 »

Hi,

https://www.youtube.com/watch?v=b_gW_-A ... e=youtu.be

This video demonstrates what is going on with this bug, but I'll post the video description here so you don't have to bother getting to it yourself.
Playing wave defence, every night my UPS drops by about 15, even though my PC is high end (GTX1070Ti, 16GBs DDR4 RAM, AMD 7 2700X) and should not have had this problem. Went off to go destroy some bases, and found this monstrosity. Using the debug menu (F4), I discovered that there were 576 biters in this clump... even at day alone, my UPS dropped to about 40, and I think this was why...

Wow okay just found 3 more of these "clumps" whilst waiting for the video to upload. They all have between 400-600 biters within about 200 tiles each...

Alright I've finished killing all the biters in them, my UPS/FPS is back up to 60.
I think the lag is caused by many of the biters trying to pathfind to attack the walls, but cannot get out of the clump because of the behemoth and big biters on the outside not pathfinding anywhere, thus blocking the inside ones.

I stupidly decided to destroy these biter clumps and save the game afterwards, so I don't have the save file (sorry) but if I encounter a "clump" again, I will be sure to send the save file of that. Log attached.

EDIT: Recorded a couple of videos researching the "clumps". https://www.youtube.com/watch?v=Sw9oS0oGlVk&t & https://www.youtube.com/watch?v=zJqQfoT ... e=youtu.be

Thanks,
Bobby
Attachments
factorio-current - Copy.log
(6.92 KiB) Downloaded 77 times
The nice thing about Windows is, it doesn’t just crash, it displays a dialog box and lets you press “OK” first :)


Tend
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sat Mar 02, 2019 9:47 pm
Contact:

[0.17.4][wave defense] Giant balls of biters causing massive lag

Post by Tend »

Playing wave defense, not all biters actually attack the base - some remain in the closest biter bases to the player spawn. Looks like they're all trying to reach the centre of the biter base, and can't get past themselves. Eventually (maybe around day 30? not sure) they build up into a giant ball with thousands of them in there. This causes significant lag - game was running about 1/3 or 1/4 speed.

Workaround is to "simply" kill them all (all the thousands of them...) and the game recovers. However, it builds up again every so often (maybe every 15 days?)

See screenshot attached for an example.

I've also attached a save file in a super laggy state where the "biter ball" exists.
Attachments
wave_defense_bug_report_2.zip
(9.47 MiB) Downloaded 73 times
20190302214302_1.jpg
20190302214302_1.jpg (1010.82 KiB) Viewed 2355 times
factorio-current.log
(6.81 KiB) Downloaded 68 times

bobby45800
Burner Inserter
Burner Inserter
Posts: 19
Joined: Sat Jan 23, 2016 10:46 am
Contact:

Re: [0.17.4] Biters getting into massive clumps and lagging

Post by bobby45800 »

Hi,

I've already have a conversation with Klonan about it, he's got the save file and many details on the issue, and I think he'll fix it after the weekend.

Thanks,
Bobby
The nice thing about Windows is, it doesn’t just crash, it displays a dialog box and lets you press “OK” first :)

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 5030
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [0.17.4] Biters getting into massive clumps and lagging

Post by Klonan »

I made some changes, this should be better now

Post Reply

Return to “Resolved Problems and Bugs”