[0.17.3] Crash on clicking fluid wagon entity in map editor

This subforum contains all the issues which we already resolved.
Post Reply
dgw
Fast Inserter
Fast Inserter
Posts: 196
Joined: Tue Apr 12, 2016 7:06 pm
Contact:

[0.17.3] Crash on clicking fluid wagon entity in map editor

Post by dgw »

Ubuntu 18.04.2, running Factorio 0.17.3 Steam build

I accidentally clicked a fluid wagon while designing a layout in the map editor mode. Factorio crashed.

My most recent autosave (attached) should start in the correct state to reproduce this. All that should be needed is to click one of the fluid wagons in one of the trains nearby.

For reference, in "factorio-current.log", I clicked the left-most fluid wagon in the top-most train. The train I clicked in "factorio-previous.log" doesn't exist yet in the autosave I have (the first, unexpected, crash was about 12 minutes into my 15-minute autosave interval, sadly), but the second log is provided anyway.

Opening other entities (locomotives, train stops, chests, refineries, silo, etc.) in editor mode has worked for me so far, FWIW. Must be something special about fluid wagons.
Attachments
factorio-current.log
(8.28 KiB) Downloaded 59 times
factorio-previous.log
(9.31 KiB) Downloaded 55 times
_autosave2.zip
(2.91 MiB) Downloaded 55 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 12219
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.3] Crash on clicking fluid wagon entity in map editor

Post by Rseding91 »

Thanks for the report. It's now fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

dgw
Fast Inserter
Fast Inserter
Posts: 196
Joined: Tue Apr 12, 2016 7:06 pm
Contact:

Re: [0.17.3] Crash on clicking fluid wagon entity in map editor

Post by dgw »

Quick fix! Thanks :)

Post Reply

Return to “Resolved Problems and Bugs”