[wheybags][0.17.3] turret with ammo requirement becomes impossible when turret first detected is gone

This subforum contains all the issues which we already resolved.
Post Reply
matjojo
Filter Inserter
Filter Inserter
Posts: 325
Joined: Wed Jun 17, 2015 6:08 pm
Contact:

[wheybags][0.17.3] turret with ammo requirement becomes impossible when turret first detected is gone

Post by matjojo »

Like the title says, I placed a turret and filled it. The game detected it and it ticket the objective, after deleting this turret with others still standing (with ammo) the objective got unticket. Image related:
factorio_2019-02-28 - 1551390900 - 00000138.jpg
factorio_2019-02-28 - 1551390900 - 00000138.jpg (298.69 KiB) Viewed 2538 times

matjojo
Filter Inserter
Filter Inserter
Posts: 325
Joined: Wed Jun 17, 2015 6:08 pm
Contact:

Re: [0.17.3] turret with ammo requirement becomes impossible when turret first detected is gone

Post by matjojo »

ow yeah, map file in here
bug objective not correct.zip
(2.17 MiB) Downloaded 130 times

TheUnknown007
Fast Inserter
Fast Inserter
Posts: 129
Joined: Sun May 03, 2015 9:17 pm
Contact:

Re: [0.17.3] turret with ammo requirement becomes impossible when turret first detected is gone

Post by TheUnknown007 »

I have a similar problem, but for me it just didn't detect it for the first turret.
After some testing it seems like there is a range around the second starting area (with the water), if you build it too far from there (i.e. close to the biters) it doesn't count.

Just a random thought, with no testing on my part whatsoever: It may have something to do with extending the map (i.e. it doesn't work on the old parts of the map)

TheUnknown007
Fast Inserter
Fast Inserter
Posts: 129
Joined: Sun May 03, 2015 9:17 pm
Contact:

Re: [0.17.3] turret with ammo requirement becomes impossible when turret first detected is gone

Post by TheUnknown007 »

After some more testing: the border where it is detected is at x=0, so that's probably not a coincidence

matjojo
Filter Inserter
Filter Inserter
Posts: 325
Joined: Wed Jun 17, 2015 6:08 pm
Contact:

Re: [0.17.3] turret with ammo requirement becomes impossible when turret first detected is gone

Post by matjojo »

That is a very probable cause, I suppose if I hand't had noticed the obvious bottleneck here I would have left the turrets to the left of the iron ore, but since this gave me more safety I went for this.

EDIT: about the x=0 thing, I assume the mapmaker just took x=0 as the left side of the map, but turns out that that is not the case here? I haven't opened up the script yet for fear of breaking stuff in my save so just waiting for the devs to reply I suppose

TheUnknown007
Fast Inserter
Fast Inserter
Posts: 129
Joined: Sun May 03, 2015 9:17 pm
Contact:

Re: [0.17.3] turret with ammo requirement becomes impossible when turret first detected is gone

Post by TheUnknown007 »

I've tested your save, if you place the turrets past the x=0 line it will detect it and complete the objective

matjojo
Filter Inserter
Filter Inserter
Posts: 325
Joined: Wed Jun 17, 2015 6:08 pm
Contact:

Re: [0.17.3] turret with ammo requirement becomes impossible when turret first detected is gone

Post by matjojo »

good to know. Will use that as workaround for now.

matjojo
Filter Inserter
Filter Inserter
Posts: 325
Joined: Wed Jun 17, 2015 6:08 pm
Contact:

Re: [0.17.3] turret with ammo requirement becomes impossible when turret first detected is gone

Post by matjojo »

Another addition, those turrets place to the west are also not being picked up by the bot in it's low ammo and damaged messages.

User avatar
wheybags
Former Staff
Former Staff
Posts: 328
Joined: Fri Jun 02, 2017 1:50 pm
Contact:

Re: [wheybags][0.17.3] turret with ammo requirement becomes impossible when turret first detected is gone

Post by wheybags »

Fixed for the next version, but only for new saves.
Thanks for the report!

Post Reply

Return to “Resolved Problems and Bugs”