[0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

This subforum contains all the issues which we already resolved.
Post Reply
Der_tolle_Emil
Burner Inserter
Burner Inserter
Posts: 7
Joined: Wed Feb 27, 2019 8:07 pm
Contact:

[0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by Der_tolle_Emil »

When I open the "Other settings" menu (where you can set the autosave interval, set developer options etc.) and I press "Back" the GUI comes up with a prompt "There is 1 unconfirmed change" even though I didn't change anything. The red reset button on the top right is disabled as well because everything is set to default. Even when changing something and then using the reset button a pressing the "Back" button will show that prompt.

The expected result obviously would be no prompt if nothing changed.

This happens every time, regardless of whether I enter the settings menu from the main menu before starting a game or during a game.

The exact version number is 0.17.2 (build 43076, win64, steam).

User avatar
CDarklock
Filter Inserter
Filter Inserter
Posts: 342
Joined: Sun Dec 03, 2017 2:17 am
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by CDarklock »

Der_tolle_Emil wrote:
Wed Feb 27, 2019 8:22 pm
When I open the "Other settings" menu (where you can set the autosave interval, set developer options etc.) and I press "Back" the GUI comes up with a prompt "There is 1 unconfirmed change" even though I didn't change anything.
Specifically the game always thinks the autosave interval has been changed.

(Also, highlighting changes is a brilliant debugging tool.)

Néomorphos
Inserter
Inserter
Posts: 28
Joined: Sun Oct 28, 2018 3:23 pm
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by Néomorphos »

also appears on map generation. when clicking "new game", you get into the generation options. The preset shows "Default [modified]" instead of expected "Default"
Attachments
20190227213531_1.jpg
20190227213531_1.jpg (347.11 KiB) Viewed 3493 times

Der_tolle_Emil
Burner Inserter
Burner Inserter
Posts: 7
Joined: Wed Feb 27, 2019 8:07 pm
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by Der_tolle_Emil »

CDarklock wrote:
Wed Feb 27, 2019 8:34 pm
Der_tolle_Emil wrote:
Wed Feb 27, 2019 8:22 pm
When I open the "Other settings" menu (where you can set the autosave interval, set developer options etc.) and I press "Back" the GUI comes up with a prompt "There is 1 unconfirmed change" even though I didn't change anything.
Specifically the game always thinks the autosave interval has been changed.

(Also, highlighting changes is a brilliant debugging tool.)
You're right. I wasn't sure whether the yellow highlight on the slider was indeed because it shows the (perceived) changed value or whether this was another bug/inconsistency that simply highlighted the first GUI element.

User avatar
CDarklock
Filter Inserter
Filter Inserter
Posts: 342
Joined: Sun Dec 03, 2017 2:17 am
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by CDarklock »

Néomorphos wrote:
Wed Feb 27, 2019 8:37 pm
also appears on map generation. when clicking "new game", you get into the generation options. The preset shows "Default [modified]" instead of expected "Default"
I think it's modified because there's a seed. I could be wrong.

Néomorphos
Inserter
Inserter
Posts: 28
Joined: Sun Oct 28, 2018 3:23 pm
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by Néomorphos »

Then it looks like it is always that THE FIRST ELEMENT OF A SETTING SCREEN IS CONSIDERED AS CHANGED.
CDarklock wrote:
Wed Feb 27, 2019 8:49 pm
Néomorphos wrote:
Wed Feb 27, 2019 8:37 pm
also appears on map generation. when clicking "new game", you get into the generation options. The preset shows "Default [modified]" instead of expected "Default"
I think it's modified because there's a seed. I could be wrong.
Der_tolle_Emil wrote:
Wed Feb 27, 2019 8:45 pm
CDarklock wrote:
Wed Feb 27, 2019 8:34 pm
Der_tolle_Emil wrote:
Wed Feb 27, 2019 8:22 pm
When I open the "Other settings" menu (where you can set the autosave interval, set developer options etc.) and I press "Back" the GUI comes up with a prompt "There is 1 unconfirmed change" even though I didn't change anything.
Specifically the game always thinks the autosave interval has been changed.

(Also, highlighting changes is a brilliant debugging tool.)
You're right. I wasn't sure whether the yellow highlight on the slider was indeed because it shows the (perceived) changed value or whether this was another bug/inconsistency that simply highlighted the first GUI element.

User avatar
CDarklock
Filter Inserter
Filter Inserter
Posts: 342
Joined: Sun Dec 03, 2017 2:17 am
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by CDarklock »

Néomorphos wrote:
Wed Feb 27, 2019 8:54 pm
Then it looks like it is always that THE FIRST ELEMENT OF A SETTING SCREEN IS CONSIDERED AS CHANGED.
This is not true. If you open graphics settings and click back, it knows nothing has changed.

And in the map settings, the seed actually has changed. So it should be considered changed, because it is.

Néomorphos
Inserter
Inserter
Posts: 28
Joined: Sun Oct 28, 2018 3:23 pm
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by Néomorphos »

We were both mistaken
EDIT: although i am not sure this is intentionnal. On top of that, i am not able to reproduce it with the "others" settings screen, where somebody said it was about autosave interval being considered as modified
20190227220153_1.jpg
20190227220153_1.jpg (352.65 KiB) Viewed 3465 times
CDarklock wrote:
Wed Feb 27, 2019 8:59 pm
Néomorphos wrote:
Wed Feb 27, 2019 8:54 pm
Then it looks like it is always that THE FIRST ELEMENT OF A SETTING SCREEN IS CONSIDERED AS CHANGED.
This is not true. If you open graphics settings and click back, it knows nothing has changed.

And in the map settings, the seed actually has changed. So it should be considered changed, because it is.

User avatar
CDarklock
Filter Inserter
Filter Inserter
Posts: 342
Joined: Sun Dec 03, 2017 2:17 am
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by CDarklock »

Néomorphos wrote:
Wed Feb 27, 2019 9:03 pm
We were both mistaken
You're right. But that only gets highlighted when you hover over the "reset" button. And I never changed it.
newgame.png
newgame.png (223.5 KiB) Viewed 3448 times
However, when I click the reset button, it does change "back."
newgame2.png
newgame2.png (27.13 KiB) Viewed 3448 times

kovarex
Factorio Staff
Factorio Staff
Posts: 8058
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by kovarex »

Tanks for the report, fixed for 0.17.2

User avatar
CDarklock
Filter Inserter
Filter Inserter
Posts: 342
Joined: Sun Dec 03, 2017 2:17 am
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by CDarklock »

Here's a weird one.

I click "New Game." It comes up as "Default (Modified)" as usual. I click the button to revert settings; it changes the "Research Queue Availability" to "After the game is finished." The title now says "Default" but not modified.

I change the setting back to "Always." The title does not change, and still says "Default" but not modified. The "Revert" button does not highlight. When I hover over it, it says "All options have preset values." But the research queue availability still highlights.
newgame4.png
newgame4.png (28.88 KiB) Viewed 3388 times
This is probably part of the fix you already did, but you know, just in case.

braiam
Inserter
Inserter
Posts: 21
Joined: Mon Jan 08, 2018 2:57 am
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by braiam »

kovarex wrote:
Wed Feb 27, 2019 9:56 pm
Tanks for the report, fixed for 0.17.2
I'm on .2 and can still reproduce.

Notsononymous
Manual Inserter
Manual Inserter
Posts: 1
Joined: Thu Feb 28, 2019 8:54 am
Contact:

Re: [0.17.2] [GUI] Settings -> Other asks for confirmation when pressing back even though nothing changed

Post by Notsononymous »

braiam wrote:
Thu Feb 28, 2019 2:05 am
kovarex wrote:
Wed Feb 27, 2019 9:56 pm
Tanks for the report, fixed for 0.17.2
I'm on .2 and can still reproduce.
Me too.


Post Reply

Return to “Resolved Problems and Bugs”