[0.17.1] Crash when erasing a ghosted belt

This subforum contains all the issues which we already resolved.
Post Reply
Grenadith
Manual Inserter
Manual Inserter
Posts: 2
Joined: Wed Feb 07, 2018 7:57 am
Contact:

[0.17.1] Crash when erasing a ghosted belt

Post by Grenadith » Wed Feb 27, 2019 3:58 am

I am playing on a server my friend is hosting off of his client. I have very high lag. When I placed down a ghost belt, it was facing an incorrect orientation, so I erased it with right-click. The game crashed immediately. This has happened to me twice within 5 minutes, and upon the second time, I knew the cause of the crash was this action.

To be more precise, I was placing a ghost belt upwards, and above that one I placed a ghost belt towards the right. I realized I meant to place it facing left instead, so I quickly attempted to erase the ghost I had just placed. I noticed that on both times the game crashed, I erased the ghost belt before it "connected" to the upward ghost belt below it (before the ghost took the curve shape instead of an regular horizontal belt).


Crash logs are attached.
Attachments
factorio-previous.log
(36.74 KiB) Downloaded 22 times
factorio-current.log
(15.88 KiB) Downloaded 22 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9780
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.1] Crash when erasing a ghosted belt

Post by Rseding91 » Wed Feb 27, 2019 6:03 am

Thanks for the report. It's now fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users