[posila] [0.17.1] IME function broken

This subforum contains all the issues which we already resolved.
Post Reply
ProjectSky
Manual Inserter
Manual Inserter
Posts: 1
Joined: Wed Feb 27, 2019 3:37 am
Contact:

[posila] [0.17.1] IME function broken

Post by ProjectSky »

Updated to 0.17.1, I can't enter Chinese messages in the game.

tehfreek
Filter Inserter
Filter Inserter
Posts: 391
Joined: Thu Mar 17, 2016 7:34 am
Contact:

Re: [0.17.1] IME function broken

Post by tehfreek »

Confirmed on Linux with a Japanese IME.

xiaoshui05
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Apr 25, 2018 10:49 pm
Contact:

Re: [0.17.1] IME function broken

Post by xiaoshui05 »

windows 10 ,the same problem :(

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.1] IME function broken

Post by posila »

tehfreek wrote:
Wed Feb 27, 2019 4:56 am
Confirmed on Linux with a Japanese IME.
In 0.16, we have added support for IME input method on Windows only. We have not added IME support for Linux/macOS in 0.17

xiaoshui05
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Apr 25, 2018 10:49 pm
Contact:

Re: [0.17.1] IME function broken

Post by xiaoshui05 »

posila wrote:
Wed Feb 27, 2019 7:11 am
tehfreek wrote:
Wed Feb 27, 2019 4:56 am
Confirmed on Linux with a Japanese IME.
In 0.16, we have added support for IME input method on Windows only. We have not added IME support for Linux/macOS in 0.17
Can you fix this bug first? Now we copy text from other places into the game, which makes our game experience very poor.

I found this, maybe it will be useful(viewtopic.php?f=6&t=23934&p=151871&hilit=IME#p151871

Jap2.0
Smart Inserter
Smart Inserter
Posts: 2338
Joined: Tue Jun 20, 2017 12:02 am
Contact:

Re: [0.17.1] IME function broken

Post by Jap2.0 »

xiaoshui05 wrote:
Tue Mar 05, 2019 3:34 am
posila wrote:
Wed Feb 27, 2019 7:11 am
tehfreek wrote:
Wed Feb 27, 2019 4:56 am
Confirmed on Linux with a Japanese IME.
In 0.16, we have added support for IME input method on Windows only. We have not added IME support for Linux/macOS in 0.17
Can you fix this bug first? Now we copy text from other places into the game, which makes our game experience very poor.

I found this, maybe it will be useful(viewtopic.php?f=6&t=23934&p=151871&hilit=IME#p151871
They aren't using Allegro anymore.
There are 10 types of people: those who get this joke and those who don't.

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.1] IME function broken

Post by posila »

Thanks for the report and sorry for taking so long to fix it.
It should be fixed in 0.17.42

Unfortunatelly, I couldn't make IME implementation in SDL work in any reasonable way so we had to port the code we used in 0.16 with Allegro.

SDL is handling windows events quite differently than Allegro did, so the code ended up being different and I hope it will work just as it used to with 3rd party IME software. I tested just with Microsoft's IME in Windows 10.

Post Reply

Return to “Resolved Problems and Bugs”