[posila] [0.17.0] Can't start game on Ubuntu

This subforum contains all the issues which we already resolved.
Post Reply
suotiikeri
Manual Inserter
Manual Inserter
Posts: 4
Joined: Tue Feb 26, 2019 5:59 pm
Contact:

[posila] [0.17.0] Can't start game on Ubuntu

Post by suotiikeri »

Hi.

When I try to open game through steam I get the error message attached(the blurred part is my home directory.)

I don't know what information is relevant here, so I will try to provide more if asked.
Attachments
Factorio error message.png
Factorio error message.png (18.77 KiB) Viewed 3593 times

Koub
Global Moderator
Global Moderator
Posts: 6752
Joined: Fri May 30, 2014 8:54 am
Contact:

Re: [0.17.0] Can't start game on Ubuntu

Post by Koub »

First, your logfile. This is always relevant for such issues.
Koub - Please consider English is not my native language.

suotiikeri
Manual Inserter
Manual Inserter
Posts: 4
Joined: Tue Feb 26, 2019 5:59 pm
Contact:

Re: [0.17.0] Can't start game on Ubuntu

Post by suotiikeri »

How do I access the logfile?


EDIT: factorio-current.log contains the following:


0.009 2019-02-26 20:28:56; Factorio 0.17.0 (build 42971, linux64, steam)
0.779 Operating system: Linux (Ubuntu 14.04)
0.779 Program arguments: "/home/[user]/.local/share/Steam/SteamApps/common/Factorio/bin/x64/factorio"
0.779 Read data path: /home/[user]/.local/share/Steam/SteamApps/common/Factorio/data
0.779 Write data path: /home/[user]/.factorio [1357603/1875274MB]
0.779 Binaries path: /home/[user]/.local/share/Steam/SteamApps/common/Factorio/bin
0.857 System info: [CPU: Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz, 2 cores, RAM: 2001 MB]
0.857 Environment: DISPLAY=:0, WAYLAND_DISPLAY=<unset>
0.857 Display options: [FullScreen: 1] [VSync: 1] [UIScale: automatic (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: en]
1.374 Available displays: 1
1.374 [0]: L568 17" - {[0,0], 1280x1024, SDL_PIXELFORMAT_RGB888, 60Hz}
1.544 Initialised OpenGL:[0] GeForce GT 440/PCIe/SSE2; driver: 3.3.0 NVIDIA 304.135
1.544 [Extensions] s3tc:yes; KHR_debug:NO; ARB_clear_texture:NO, ARB_copy_image:NO
1.544 [Version] 3.3
3.146 Error Util.cpp:75: Failed to compile program '/home/[user]/.local/share/Steam/SteamApps/common/Factorio/data/core/graphics/shaders/fullscreen-quad.vert, /home/[user]/.local/share/Steam/SteamApps/common/Factorio/data/core/graphics/shaders/mipmap-gen-rygDXT.frag'.
Fragment info
-------------
0(102) : warning C7050: "index" might be used before being initialized
0(16) : warning C7050: "fragColor.zw" might be used before being initialized
0(163) : error C5041: cannot locate suitable resource to bind parameter "@TMP67-0116"
0(168) : error C5041: cannot locate suitable resource to bind parameter "@TMP68-0118"
0(163) : error C5041: cannot locate suitable resource to bind parameter "@TMP67-0120"
0(163) : error C5041: cannot locate suitable resource to bind parameter "@TMP67-0141"
0(168) : error C5041: cannot locate suitable resource to bind parameter "@TMP68-0143"
0(163) : error C5041: cannot locate suitable resource to bind parameter "@TMP67-0145"
0(163) : error C5041: cannot locate suitable resource to bind parameter "@TMP67-0147"
0(168) : error C5041: cannot locate suitable resource to bind parameter "@TMP68-0149"
0(163) : error C5041: cannot locate suitable resource to bind parameter "@TMP67-0151"

23.848 Steam API shutdown.
24.127 Goodbye


Note that I have replaced username with [user], since it is my real name.

orzelek
Smart Inserter
Smart Inserter
Posts: 3898
Joined: Fri Apr 03, 2015 10:20 am
Contact:

Re: [0.17.0] Can't start game on Ubuntu

Post by orzelek »

Try to check if there is a driver update for your GPU.
It seems that this GPU should work with upgraded game engine but it fails to compile shader for some reason.

suotiikeri
Manual Inserter
Manual Inserter
Posts: 4
Joined: Tue Feb 26, 2019 5:59 pm
Contact:

Re: [0.17.0] Can't start game on Ubuntu

Post by suotiikeri »

Thanks, I updated the drivers and now I have a different error message. I'm going to count that as a success and create a separate topic for the new error.

Does this mean my problem wasn't actually a bug? If so, what should I do with this topic?

vjbone
Long Handed Inserter
Long Handed Inserter
Posts: 97
Joined: Sun Feb 14, 2016 10:02 am
Contact:

Re: [0.17.0] Can't start game on Ubuntu

Post by vjbone »

windows
same error on start
Attachments
factorio-current (3).log
(2.16 KiB) Downloaded 96 times

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.0] Can't start game on Ubuntu

Post by posila »

vjbone wrote:
Wed Mar 06, 2019 7:23 am
windows
same error on start
Hi, on Windows 7, try to install this update: https://www.catalog.update.microsoft.co ... =KB4019990 (it installs d3dcompiler_47.dll)
The game should be able to use DirectX renderer after that.

On Linux, you can try to update the graphics driver; I will make a workaround

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.0] Can't start game on Ubuntu

Post by posila »

Thansk for the report.
It's not extactly bug in the game, but for 0.17.10 I changed the code so if non-essential shaders fail to compile, the game can still run.

Post Reply

Return to “Resolved Problems and Bugs”