[0.16.51] Text in Bonuses tab duplicates upon finishing research

This subforum contains all the issues which we already resolved.
Post Reply
Grimmer288
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sat Dec 02, 2017 2:49 am
Contact:

[0.16.51] Text in Bonuses tab duplicates upon finishing research

Post by Grimmer288 » Sun Jan 27, 2019 2:05 am

After starting the game without any mods loaded, I started a new world. I opened the bonuses tab while messing around, then researched Automation with the tab still open. The tab currently reads "No bonuses researched yet." As soon as the research finished, the text in the Bonuses tab box duplicated to read "No bonuses researched yet. No bonuses researched yet." As far as I know, the only time this happens is when researching something that does not add a bonus with no existing bonuses.

This bug is reproducible. You must also have no existing bonuses in order for this to work. It happens when there are no bonuses researched yet and the research will not add a bonus. If you close and open the bonuses tab after the text duplicates, it reverts to only reading "No bonuses researched yet.".

What I think should happen is for nothing to change in the bonuses tab, as no bonuses were added and there is no point in duplicating the text.
Attachments
Factorio Bonuses glitch.mp4
A video of the glitch being reproduced.
(5.75 MiB) Downloaded 29 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9847
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.51] Text in Bonuses tab duplicates upon finishing research

Post by Rseding91 » Sun Jan 27, 2019 4:02 am

Thanks for the report. It's now fixed for 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: Google [Bot]