[Rseding91] [16.51] Desync on join

This subforum contains all the issues which we already resolved.
Post Reply
ekimekim
Burner Inserter
Burner Inserter
Posts: 17
Joined: Wed Dec 13, 2017 11:40 pm
Contact:

[Rseding91] [16.51] Desync on join

Post by ekimekim » Sat Jun 30, 2018 11:26 pm

We discovered today that we cannot connect to our multiplayer server - immediately after loading the map, when it would normally begin catching up, it immediately desyncs.
This is tested on several client computers on Windows and Linux. The server itself is Linux. Desync report uploaded here is Linux:

https://drive.google.com/drive/u/1/fold ... x4pxE1hxmm

This server runs even when no players are connected so something must have happened to trigger this condition while we weren't connected.
It's a very large world with an RPM base and accompanying science base.
The only recent significant change was a new nuclear plant design, but that's been running for several days without issues.

ekimekim
Burner Inserter
Burner Inserter
Posts: 17
Joined: Wed Dec 13, 2017 11:40 pm
Contact:

Re: [16.51] Desync on join

Post by ekimekim » Sat Jun 30, 2018 11:49 pm

We tried restarting the factorio server, and somehow this fixed the problem. Here is the working save file:
https://drive.google.com/open?id=14v71p ... 4eXS7tuO24

And attached is the current (while it's working) and previous (while it wasn't) server logs.
Attachments
factorio-previous.log
(180.46 KiB) Downloaded 15 times
factorio-current.log
(4.65 KiB) Downloaded 13 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 8845
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [16.51] Desync on join

Post by Rseding91 » Sun Jul 01, 2018 7:25 pm

Thanks for the report. It's now fixed for 0.17. The issue is related to the car-belt you've got in your save. That logic is simply broken in 0.16.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users and 2 guests