[kovarex] [0.16.42] Crash: EntityGhost::checkConsistency fails

This subforum contains all the issues which we already resolved.
Post Reply
jrodmcb
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat May 12, 2018 12:54 am
Contact:

[kovarex] [0.16.42] Crash: EntityGhost::checkConsistency fails

Post by jrodmcb » Sat May 12, 2018 1:05 am

I used steam's automatic patcher and loaded up 16.42, attempted to load the save game that I have not had a problem loading. It crashed after clicking the load button, bringing up an unexpected error occurred message.

I downgraded to 16.41 which was working yesterday, and the same thing occurred.

Attached is the save in question and the log file
enabled mods
although many of these aren't in active use in the same
Attachments
016_bh.zip
(19.46 MiB) Downloaded 29 times
factorio-current.log
Log
(10.57 KiB) Downloaded 43 times

kovarex
Factorio Staff
Factorio Staff
Posts: 7387
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.16.42] Crash: EntityGhost::checkConsistency fails

Post by kovarex » Sat May 12, 2018 2:10 pm

Hello, I checked the save, and for some reason on the position of {1011.5, 72.5} there is an ghost express underground belt on top of fast underground belt. This shouldn't be normally possible, do you have any idea how did it happen?

Edit: There are actually much more of these around.
Attachments
the-problem.jpg
the-problem.jpg (239.81 KiB) Viewed 1524 times

jrodmcb
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat May 12, 2018 12:54 am
Contact:

Re: [kovarex] [0.16.42] Crash: EntityGhost::checkConsistency fails

Post by jrodmcb » Sat May 12, 2018 5:12 pm

I was using a mod called belt upgrader that is to automatically place blue belts over red. It does seem a bit inconsistent at times as to whether it properly calls for the old belt to be deconstructed, as sometimes even though a bot is hovering over the location with a blue belt held, the red belt that is already placed there will keep moving and transporting items.

kovarex
Factorio Staff
Factorio Staff
Posts: 7387
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.16.42] Crash: EntityGhost::checkConsistency fails

Post by kovarex » Sat May 12, 2018 6:11 pm

jrodmcb wrote:I was using a mod called belt upgrader that is to automatically place blue belts over red. It does seem a bit inconsistent at times as to whether it properly calls for the old belt to be deconstructed, as sometimes even though a bot is hovering over the location with a blue belt held, the red belt that is already placed there will keep moving and transporting items.
YES! This information was the critical part that allowed me to figure out what was causing that. Thank you very much.
The bug is fixed for 0.16.43.

It also makes the mod "do nothing" as it tried to do something invalid, but if the mod creator adjusts his code to mark the previous belt for deconstruction, it can easily work again.

jrodmcb
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat May 12, 2018 12:54 am
Contact:

Re: [kovarex] [0.16.42] Crash: EntityGhost::checkConsistency fails

Post by jrodmcb » Sat May 12, 2018 6:45 pm

Cool, thanks!

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users